Kawasaki Versys Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello all,
new rider, sorry if this is a basic question, though in searches I haven't found a working answer yet. Most discussions on turn signals seem to be aftermarket signals and timing and this is a simple stock issue.

I laid my 2009 Versys down recently, not bad but I did break the front turn signal, so I ordered and swapped out the assembly, but still neither turn signal works. The most common solution I could find was to change out the turn signal relay, so I replaced that as well, but still not working.

Any other suggestions to try? I'm not much of a technical guy, so understanding electrical systems, diagrams and such is all still new to me, but wondering if there is anything else recommended.

Thanks all, this is a very useful forum and community.

Tyson
 

·
Registered
Joined
·
7 Posts
You tried checking the fuse?

Under the seat in a little black box I believe, should be quite clearly marked which one relates to the turn signals.

And when you say 'I did break the front turn signal, so I ordered and swapped out the assembly' are you talking about the switch gear on the handlebar?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
You know, I didn't check the fuse, let me go do that this morning, seems silly, one of the first and easy things to check but maybe I'll get lucky and it will be that simple.

Ya, the bulb and turn signal housing broke, so that was the assembly I talked about replacing, I didn't just swap out the bulb, but the whole front turn signal.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Hmm, well now I feel just foolish, it was the fuse, why I didn't think to check that, I don't know.

Thanks much, quite a simple fix, I was going totally in the wrong and more difficult direction, but working great now!
 

·
Registered
Joined
·
235 Posts
Don't feel too bad. Back when I had a sportster, there was a guy on the forum that couldn't get his bike in gear. It would seem to shift and rev fine, just seemed like the tranny wouldnt engage. So he started pulling his transmission out. (2003 and earlier had a trap door to access the tranny). All the while he had a broken drive belt.
 

·
Registered
Kawasaki Versys 2019 ABS
Joined
·
179 Posts
Same glitch with my bike today. I fitted a set of aux lights by Gold Runway and after that, no turn indicators. The hazard warning is also kaput. Relay seems ok. And, in my 2019 model, the fuzebox does not have a label for the fuse that works on the turn indicator circuit. What could be the problem?
 

·
Premium Member
Joined
·
11,119 Posts
Did you try the lights on a 12 volt source? As to four way-no magic here, it uses the same circuit just parallels the right or left signal. Are these LED? The way it works is 12 vots goes directly to the flasher, from the flasher it goes to the turn signal switch and 4way, the 4 way bridges the left and right and is common to the flasher relay along with the left and right. From the turn signal we have two wires, left and right, they have a tap off each for the rear signal lights. Simple,
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top