Kawasaki Versys Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all,
new rider, sorry if this is a basic question, though in searches I haven't found a working answer yet. Most discussions on turn signals seem to be aftermarket signals and timing and this is a simple stock issue.

I laid my 2009 Versys down recently, not bad but I did break the front turn signal, so I ordered and swapped out the assembly, but still neither turn signal works. The most common solution I could find was to change out the turn signal relay, so I replaced that as well, but still not working.

Any other suggestions to try? I'm not much of a technical guy, so understanding electrical systems, diagrams and such is all still new to me, but wondering if there is anything else recommended.

Thanks all, this is a very useful forum and community.

Tyson
 

·
Registered
Joined
·
7 Posts
You tried checking the fuse?

Under the seat in a little black box I believe, should be quite clearly marked which one relates to the turn signals.

And when you say 'I did break the front turn signal, so I ordered and swapped out the assembly' are you talking about the switch gear on the handlebar?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
You know, I didn't check the fuse, let me go do that this morning, seems silly, one of the first and easy things to check but maybe I'll get lucky and it will be that simple.

Ya, the bulb and turn signal housing broke, so that was the assembly I talked about replacing, I didn't just swap out the bulb, but the whole front turn signal.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Hmm, well now I feel just foolish, it was the fuse, why I didn't think to check that, I don't know.

Thanks much, quite a simple fix, I was going totally in the wrong and more difficult direction, but working great now!
 

·
Registered
Joined
·
237 Posts
Don't feel too bad. Back when I had a sportster, there was a guy on the forum that couldn't get his bike in gear. It would seem to shift and rev fine, just seemed like the tranny wouldnt engage. So he started pulling his transmission out. (2003 and earlier had a trap door to access the tranny). All the while he had a broken drive belt.
 
1 - 8 of 8 Posts
Top