Kawasaki Versys Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2013 650 and about a week I popped a wheelie and when I touched down my engine immediately shut off. Now when I crank it it will idle and when I give it throttle it shuts off .I replaced the tip over sensor already but that didn't fix it tried to see if it would run with the kickstand up and and gear and that hasn't done it there's so much electronical stuff on there I really don't know where to start
 

·
Registered
Joined
·
33 Posts
I would start with wiring and connectors including fuses. Something came loose or some open wires started touching each other. See what voltage meter reads at idle and before it shuts off

And by shuts off, you mean dashboard remains on?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes it shuts off and the dash lights remains on. I can take and crank it and not touch the throttle and it will sit there and idle for a short period Of time and then die out. I called myself checking all the wires and whatnot I didn't really see anything a loose or bear.
 

·
Registered
Joined
·
33 Posts
Yes it shuts off and the dash lights remains on. I can take and crank it and not touch the throttle and it will sit there and idle for a short period Of time and then die out. I called myself checking all the wires and whatnot I didn't really see anything a loose or bear.
If you are sure its not a kickstand issue and battery is somewhat charging when idling then you probably need to go a bit deeper, check:
Starter relay
Ground connectors
Fuel hose
Coils and spark plugs
 

·
Registered
Joined
·
1,233 Posts
Sounds like fuel starvation. So maybe the fuel pump is not energized. I can't think of a sensor that would allow idling but then kill it if you ask for more power/rpm.
 

·
Premium Member
Joined
·
9,193 Posts
what would happen if the throttle position sensors were thrown off?
Good One
Have a look at this thread:
 

·
Premium Member
Joined
·
9,193 Posts
I have a 2013 650 and about a week I popped a wheelie and when I touched down my engine immediately shut off. Now when I crank it it will idle and when I give it throttle it shuts off .I replaced the tip over sensor already but that didn't fix it tried to see if it would run with the kickstand up and and gear and that hasn't done it there's so much electronical stuff on there I really don't know where to start
Too bad you didn't post before buying, a tip over switch will give no error and the bike will idle for about 3 seconds, trying a second time while the key remains on, will result in nothing. The only way it will start is keying off and on again.
You have a 2013, which had a very low incidence of vehicle down sensor / tip over switch failures compared to the MK-3 2015 on 650 ABS Versys.
I included a link above for good reason, the MK-1 and MK-2 had engine mounting bolt problems, also frame clearance issues.
Here is a list of things I would check, some accurate information also needs to be posted by you, idling for a while could be 3 seconds or 3 minutes, big difference.
FYI the 2013 used part of the display for some sensor power.
#1 , when it stops will it restart by pushing the start button? = if a key off is needed, you need to follow the testing vehicle down sensor Vehicle Down / Tip Over Sensor / Testing/ Work around
#2 have a close look at the TPS also are you sure you don't have a engine malfunction / error code showing? I would advise following the post checking the TPS
#3 if the idle is longer than 3 seconds, please measure the time as accurately as possible and give the idle RPM , also give the volts DC at the battery, only if idle is longer than 2 minutes
#4 Is the headlight on? at idle
#5 Have you checked the battery connections ? Have you checked your engine mounting bolts?
 
1 - 8 of 8 Posts
Top