Kawasaki Versys Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Anybody troubleshoot and replaced starter or starter parts around 30K miles? Just started getting a terrible whine/growl for a minute or two after starting my bike cold, now nothing when I hit the starter button, not ticking, clicking and certainly no cranking. When I bump started I got the whine/growl and thinking it might be the starter I put my hand on it and waited...sure enough it had a vibration that stopped when the noise stopped. planning on breaking it down, just wanted to know if anyone's got insight...like it might just be the brushes or replace the whole thing. Thx in advance.

another element too; just had Kawasaki change out the stator; could that have screwed things up?
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
fuses are good. headlight relay popped, so can't check the dimming. Chasing down a bigger issue with stator and r/r when the whining then dieing starter happened.
 

·
Registered
Joined
·
391 Posts
If you can get your motor running, check the charge rate with a volt meter across the battery. Should read at least 14 volts. It may have been overcharging, blown the headlight bulbs and fried the battery. This test will point you in a general direction.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #6 ·
thanks to all. it appears the starter issues were linked to the stator, r/r, and relay box issues. once these three pieces were replaced all is working well. taking the starter apart turned out to be really easy and straight forward and all tested fine (only 30K after all)
Thanks again for the help
 
1 - 6 of 6 Posts
Top