Kawasaki Versys Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1 (Edited)
Wondering if anyone has experienced this? I think this cropped up right after I installed a LV slip on (baffle in.)

I thought it was exhaust leakage at the slip joint (verified during a seafoam spray session, saw white smoke at joint) so I sealed it the other day with RTV Copper.

However I still get this spitting/coughing with a sudden drop in RPMs for a split second, and then picks right back up. My cold idle will go up to about 3k rpm, and this especially happens around there.

Breakdown of whats happening:

Starts on the 2nd turn
Revs up to about 3k in around 2 seconds
Spitting starts, drops down to 2-2.5k momentarily, then back up to 2.5-3k.
Couple more spits, then it steadies around 2k for a minute. No more spits.
Drops down to 1.3k when fully warmed. Runs perfect.

My mods include LV slip on, BMC filter, and PCIII USB.
Valves were done at 15k and not due for another 10k. Starts up right away so I don't think it's tight valves.

I'm about to take it to the dealer, but will also try a 0 map on the PCIII to see if the PCIII is the cause. Maybe causing strange fueling (at idle).
 

·
Super Moderator
Joined
·
7,683 Posts
Wondering if anyone has experienced this? I think this cropped up right after I installed a LV slip on (baffle in.)

I thought it was exhaust leakage at the slip joint (verified during a seafoam spray session, saw white smoke at joint) so I sealed it the other day with RTV Copper.

However I still get this spitting/coughing with a sudden drop in RPMs for a split second, and then picks right back up. My cold idle will go up to about 3k rpm, and this especially happens around there.

Breakdown of whats happening:

Starts on the 2nd turn
Revs up to about 3k in around 2 seconds
Spitting starts, drops down to 2-2.5k momentarily, then back up to 2.5-3k.
Couple more spits, then it steadies around 2k for a minute. No more spits.
Drops down to 1.3k when fully warmed. Runs perfect.

My mods include LV slip on, BMC filter, and PCIII USB.
Valves were done at 15k and not due for another 10k. Starts up right away so I don't think it's tight valves.

I'm about to take it to the dealer, but will also try a 0 map on the PCIII to see if the PCIII is the cause. Maybe causing strange fueling (at idle).
You mean exhaust backfire
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
It sounds like it's coming from around the intake & throttle body area, not the exhaust. I'm familiar with exhaust backfire and this doesn't seem to be that.

The sound is more like a slight cough or spit accompanied with momentary drop in idle speed.
 

·
Registered
Joined
·
3,157 Posts
i have an 08 with almost 40k on it motor is all stock and mine will do the hick up thru the intake thing too on a rare action. only happens when i blurp the throttle and is kindo of a rare thing with mine.. yours sounds more problematic.... can you get it on video?
 

·
Registered
Joined
·
44 Posts
Discussion Starter #5
Solved.

Was an exhaust leak from the headers. Must have flexed a bit when doing the muffler change. Tightened them up and spitting is gone. Might wanna check the header bolts on yours too @silviefox
 

·
Registered
Joined
·
3,157 Posts
Solved.

Was an exhaust leak from the headers. Must have flexed a bit when doing the muffler change. Tightened them up and spitting is gone. Might wanna check the header bolts on yours too @silviefox
oh im sure mine is coming from the air-box, probably due to valves or intakes needing a re-synced
 
1 - 6 of 6 Posts
Top