Kawasaki Versys Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I just thought I'd let everyone know how my install of the speedodrd on my 2017 model went. According to 12oclock labs who makes the speedodrd the 2017 model has no VSS sensor to insert the speedodrd inline with plugs like is a normal install for most bikes. I guess I should have pulled off the countershaft sprocket cover to check! Oh well too late now. I suspect they are right because I put on a 43T rear sprocket to tame the highway revs and hopefully fix the speedo error but it didn't affect the speedo reading at all, based on that it makes sense that the ecu is getting the speed info from the abs wheel sensors.

With no VSS you have to tap into the wire going from the ecu to the speedo cluster which I did right behind the cluster. On my bike it was the pink wire, and you also have to tap into some switched positive power and a ground. It's fairly simple soldering but if you are not comfortable soldering I would not recommend this project.

Unfortunately my bike had no speedo reading after installing the speedodrd. I tried different settings recommended by the manufacturer but no luck. I had many emails with 12oclock labs about things to try until finally one worked! I had to add a pullup resistor of 4.7kohm from my 12V+ wire to the pink wire into the cluster. The easiest way I could see to do that was to pull the heatshrink cover off the speedodrd board and solder the resistor directly where the wires attach. Then I resealed the board up with heatshrink. I was half afraid I was going to burn something up but Brooks from 12oclock labs was patient and encouraging through this whole process so I went for it. It worked!

I'm happy my speedo is perfectly accurate now, it bugged me to be off as far as it was before but I'm honestly not sure if I'd do it again as much work as it ended up being to finally make it work.

Here's a couple pics and if anyone has any questions on installing this let me know or contact 12oclocklabs and they were more than helpful in this whole endeavour.

Kirk.
 

Attachments

·
Premium Member
Joined
·
9,107 Posts
I just thought I'd let everyone know how my install of the speedodrd on my 2017 model went. According to 12oclock labs who makes the speedodrd the 2017 model has no VSS sensor to insert the speedodrd inline with plugs like is a normal install for most bikes. I guess I should have pulled off the countershaft sprocket cover to check! Oh well too late now. I suspect they are right because I put on a 43T rear sprocket to tame the highway revs and hopefully fix the speedo error but it didn't affect the speedo reading at all, based on that it makes sense that the ecu is getting the speed info from the abs wheel sensors.

With no VSS you have to tap into the wire going from the ecu to the speedo cluster which I did right behind the cluster. On my bike it was the pink wire, and you also have to tap into some switched positive power and a ground. It's fairly simple soldering but if you are not comfortable soldering I would not recommend this project.

Unfortunately my bike had no speedo reading after installing the speedodrd. I tried different settings recommended by the manufacturer but no luck. I had many emails with 12oclock labs about things to try until finally one worked! I had to add a pullup resistor of 4.7kohm from my 12V+ wire to the pink wire into the cluster. The easiest way I could see to do that was to pull the heatshrink cover off the speedodrd board and solder the resistor directly where the wires attach. Then I resealed the board up with heatshrink. I was half afraid I was going to burn something up but Brooks from 12oclock labs was patient and encouraging through this whole process so I went for it. It worked!

I'm happy my speedo is perfectly accurate now, it bugged me to be off as far as it was before but I'm honestly not sure if I'd do it again as much work as it ended up being to finally make it work.

Here's a couple pics and if anyone has any questions on installing this let me know or contact 12oclocklabs and they were more than helpful in this whole endeavour.

Kirk.
Well unless they changed the 2017, I find what you are saying hard to believe , BTW always state what model , even though you are in the V650 , mistakes happen, I checked your profile and it says 650LT. So my question, is there a sensor at the countershaft sprocket? That would be helpful . My 2015 has a sensor there, and I assume changing the sprocket would change the speedo, as I did this on my 07 Versys with a 16T sprocket.
 

·
Registered
Joined
·
342 Posts
On my 2011 gen 2 V. I changed the rear sprocket to 44T and now my speedo is bang on (with new tire). Revs are down a bit at hiway speed and less jerky throttle at low speed. I didn’t notice a change in performance.

My point is you may want to try a sprocket size change when it is time for a new chain at least for gen 1 or 2 to correct the speedo.
 

·
Registered
Joined
·
1,189 Posts
On my 2011 gen 2 V. I changed the rear sprocket to 44T and now my speedo is bang on (with new tire). Revs are down a bit at hiway speed and less jerky throttle at low speed. I didn’t notice a change in performance.

My point is you may want to try a sprocket size change when it is time for a new chain at least for gen 1 or 2 to correct the speedo.
I got the same results with a 44T rear sprocket on my 2015 Versys 650 ABS. Speedometer and GPS indicated speeds are now in sync. :)
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Sorry guys didn't notice the replies until now,

I actually did try a 43t on the rear first and that didn't do anything to correct the speedo error. It made the gearing feel better as far as shifting and revs was concerned.
 
1 - 5 of 5 Posts
Top