Kawasaki Versys Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey V owners. I just got my 2012 V 2 weeks ago. The first digit on the speedo, 8 when you turn the ignition on. On mine the top left side of the 8 is missing meaning the 2,4,6,8 and 9 have a part of the digit missing. I took it to the dealer who had the mechanic look at it. They came back with "oh we checked the other bike we have in stock and its the same so that's the way they are". I say" B.S." So true or false?. Anyone else with this issue or is it in fact they way they are. I don't ever expect to hit 200 km's an hour to need it, but for the $10 grand I spent on the bike I expect everything to be perfect. Feedback please. :(
 

·
Registered
Joined
·
688 Posts
Normal for mine. Guess they don't expect that digit to ever need the upper bar.
 

·
Registered
Joined
·
55 Posts
Just checked my 2011 V, it is missing as well.

Though when you think about it, when will you need/be able to get to higher than the 100 mph range? Technically, it wouldn't need to be anything other than a 1, right?

Edit: I was thinking about MPH only, you would need the 2 for KPH as Invader showed in the video.
 

·
Registered
Joined
·
1,251 Posts
I guess we've figured out by now that the missing segment of the display is not used to display a two (or a three). It probably saved Kawasaki a tenth of a cent to eliminate that segment but it all adds up to a significant savings in the end I suppose. Smart.
 

·
Registered
Joined
·
8,000 Posts
We all have the same instrument cluster which can be switched from mph to Km/hr... What you're missing is not the top LCD line, but the upper left which would be needed only for a 4, 5, 6, 8, 9 or 0.
 

·
Registered
Joined
·
55 Posts
If you really are missing the top LCD line instead of the upper left, perhaps that's the way it cycles on when you're set to mph instead of Km/hr.
Nope, mine cycles in MPH and it shows all but the upper left (which is the one I think he is talking about)

If it is is is showing :
___
.....|
|....|
____
He should be fine

If it is this :

.....|
|....|
___
Than there is a problem....
Sorry if my crude keyboard drawings confuse anybody. (periods are blank spots...)
 

·
Registered
Joined
·
8,000 Posts
That's right... He did say the top left, but mentioned digit '2' which is not affected, unless he meant both top left corner bars.

On mine the top left side of the 8 is missing meaning the 2,4,6,8 and 9 have a part of the digit missing.
So, yes it is perfectly normal to be missing only the one top LCD bar. It's the same on all Versys instrument clusters... It would only be needed to show 400+ Km/hr or mph.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Terboy- Thanks for the replies. And yes my bad on the 2 digit, it is just 4,6,8 and 9 affected. " My bad" as well on the whole issue. I was just reading through my operating manual and it actual shows it missing in there. But, "how cheap is that!" on Kawasaki's part to leave it out. 'Go figure!". I love the bike anyway.
 
1 - 12 of 12 Posts
Top