Kawasaki Versys Forum banner

1 - 16 of 16 Posts

·
Premium Member
Joined
·
16,191 Posts
Discussion Starter #1
 

·
Premium Member
Joined
·
16,191 Posts
Discussion Starter #3
I love my Stebel air horn....I don't use it much, but when I do its gets the attention it deserves :wink2:

Yep, I've put one on my last 3 bikes. It's usually one of the first things i do but with the V-1000 it was hard to find a spot for it so i separated the horn from the resonator then installed it....

P1010739 by weljo2001, on Flickr

P1010741 by weljo2001, on Flickr
 

·
Premium Member
Joined
·
16,191 Posts
Discussion Starter #5
That's genius...its exactly like the Denali split horn that they just came out with...you should have patented that idea...:)


Well its been done long before i did it. I did cut off the excess black plastic that held the compressor.
 

·
Super Moderator
Joined
·
19,436 Posts
I love my Stebel air horn....I don't use it much, but when I do its gets the attention it deserves :wink2:
I had my son riding pillion w/ me, in traffic, once, and a car was starting into our lane from my right. I hit the horn button (Stebel Nautilus, since replaced by a WOLO Bad Boy when it failed) and the approaching vehicle almost rolled getting out of our lane, obviously thinking we were a Peterbilt or Kenworth.

LOVE having a decent horn!!!
 

·
Premium Member
Joined
·
16,191 Posts
Discussion Starter #7
My horn has paid for itself a long time ago....Leaving from lunch today....
 

·
Super Moderator
Joined
·
19,436 Posts
I had an issue w/ my '08 and its WOLO Bad Boy horn about a year or two back.

I pulled up (in a right-turn lane) behind a woman in an SUV (right-turns OK on the red in AZ), and she's just sitting there. An LEO in his cruiser is on the right shoulder. I wait a bit (NO traffic coming from the left), then 'tap' the horn. She's STILL not moving (NOW the light has turned green), so I gave her a couple of longer 'beeps'.

FINALLY she starts moving, as do I, and I see the LEO's beacons come on, following us into the right turn, then he pulled ME over. I asked WHY he had pulled me over when she was obviously not watching traffic (I sort of wondered IF she was impaired...), and he told me that you can ONLY use your horn in emergencies. I said "But she's obviously NOT watching traffic!" to which he replied "You don't know what was in front of her!" which OF COURSE I did - NOTHING!

:huh:
 

·
Registered
Joined
·
4,701 Posts
I had an issue w/ my '08 and its WOLO Bad Boy horn about a year or two back.

I pulled up (in a right-turn lane) behind a woman in an SUV (right-turns OK on the red in AZ), and she's just sitting there. An LEO in his cruiser is on the right shoulder. I wait a bit (NO traffic coming from the left), then 'tap' the horn. She's STILL not moving (NOW the light has turned green), so I gave her a couple of longer 'beeps'.

FINALLY she starts moving, as do I, and I see the LEO's beacons come on, following us into the right turn, then he pulled ME over. I asked WHY he had pulled me over when she was obviously not watching traffic (I sort of wondered IF she was impaired...), and he told me that you can ONLY use your horn in emergencies. I said "But she's obviously NOT watching traffic!" to which he replied "You don't know what was in front of her!" which OF COURSE I did - NOTHING!

:huh:
I have not had great luck with the compact air horns. They just don't seem to last. I started leaving the stock horn in place and use the stock horn connections to trigger the relay for the air horn. That way if the air horn dies I still have the beep beep. I have thought of adding a delay in the relay so if I just quickly tap the horn button I only get the stock horn and if I hold it the air horn kicks in. That would have saved you from the cop situation.

I do agree that horns should only be used in emergencies. When overused people get complacent and don't react to them.

I put these 6 inch electric horns on my Vulcan Voyager.

 

·
Premium Member
Joined
·
16,191 Posts
Discussion Starter #10
I'm on my 3rd Stebel Horn. The first one on the 09 V-650 installed it in 2010 and left it on the bike when i sold it in 2014. The second i bought for the FJR i was playing with mounting spots and didn't have it secure enough so that one came off the bike between home and malibu. The 3rd one i mounted properly on the FJR and used it till i traded the bike in on the Versys 1000 last July so took the horn off the FJR and installed it on the 1000. Have never had an issue with the Stebel horn except the one that was my fault....
 

·
Registered
Joined
·
48 Posts
Mr wealth of information and help on the Versys\;]
If you have mentioned where and which model I have missed it, Im doing a few upgrades on LEDs and will include this horn as well, amazon or and which model?
Thanks in advance.
 

·
Premium Member
Joined
·
16,191 Posts
Discussion Starter #13
Mr wealth of information and help on the Versys\;]
If you have mentioned where and which model I have missed it, Im doing a few upgrades on LEDs and will include this horn as well, amazon or and which model?
Thanks in advance.


This is the one i have now but they offer a chromed version for about 10 bucks more....https://www.amazon.com/Stebel-11690019-Nautilus-Compact-Black/dp/B00CMX20H4/ref=sr_1_1?ie=UTF8&qid=1499100717&sr=8-1&keywords=stebel+nautilus+air+horn .... I always get the wiring kits makes it easy for me......https://www.amazon.com/Universal-Plug-n-Play-Wiring-Harness-Motorcycle/dp/B0028ZKMM6/ref=pd_bxgy_263_img_2?_encoding=UTF8&pd_rd_i=B0028ZKMM6&pd_rd_r=88SCQAD5S0FRAP87WYBC&pd_rd_w=aMBj6&pd_rd_wg=fala7&psc=1&refRID=88SCQAD5S0FRAP87WYBC
 

·
Super Moderator
Joined
·
19,436 Posts
Here's a pic of the STEBEL Nautilus on my '08



and here's its replacement WOLO Bad Boy on my '15 (replaced the STEBEL when it 'died').
 

Attachments

·
Registered
Joined
·
230 Posts
Having a hard time getting my Wolo horn to work. Tested it by itself and it works, when all wired up to the relay it just clicks at the relay. Not sure what I'm missing.
 

·
Registered
Joined
·
1,210 Posts
Having a hard time getting my Wolo horn to work. Tested it by itself and it works, when all wired up to the relay it just clicks at the relay. Not sure what I'm missing.
Can you explain how each connection (with the connection number) is set up on your relay?
 
1 - 16 of 16 Posts
Top