Kawasaki Versys Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
it's most common upshifting to 2nd gear, however it's happened a few times in the higher gears. It does't happen often however it's happened enough to have me concerned. Any ideas on whats going on?

Thanks,

rlj
 

·
Registered
Joined
·
7,983 Posts
::::
It might need lubing. Left footpeg has to be removed from mounting plate to properly clean and grease the shifter lever's sealed main pivot. You can also grease the two small rod-end links.
Squirting some chain lube on the main link sides may help for now as a quick fix.
Remove your left footpeg to clean out and grease pack the shifter's main pivot. You can also spray some chain lube on the links under the rubber boots at both ends of the adjuster rod.
 

·
Super Moderator
Joined
·
19,018 Posts
SOMETIMES I've encountered shifting problems when wearing new boots, until they get broken in. Happens mostly with stiff boots like MX ones.
:goodluck:
 

·
Registered
Joined
·
11 Posts
Had this issue just yesterday except the other way around. Went down a gear and lever wouldn't come back up! An absolute pain on roundabouts. Got home, sprayed half a can of degreaser around the area, lever pivot and the actual gear change pivot closer to the engine. Then WD40 around the pivots.

It was a case of:

Does it move - Nope.
Should it move - Yep
Use WD40

All good now!
 

·
Registered
Joined
·
7,983 Posts
You should still do it properly by removing the footpeg mount to access the shifter's sealed main pivot to clean and grease it.
 
1 - 9 of 9 Posts
Top