Kawasaki Versys Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I recently cleaned my chain and sprockets then reapplied some castrol chain lube (spray). Left it on overnight. The next time I went for a ride I found my back wheel and exhaust are covered in chain muck. I didn't use much to begin with.. The spray can is about 5 years old, is that the issue? It's past its use by date? (nothing on the can though) :confused:
 

·
Super Moderator
Joined
·
16,056 Posts
I'm on my last can of Dupont Teflon Chain Lube that i bought in 2011. I've had no issues. Just cleaned and lubed the chain yesterday...
 

·
Registered
Joined
·
308 Posts
I'm on my last can of Dupont Teflon Chain Lube that i bought in 2011. I've had no issues. Just cleaned and lubed the chain yesterday...
I also bought a case of the Dupont lube back in 2006 and also have one can left- but I will not use it on any bike because from what have I read the reason or one of the reasons Dupont quit making it was the shelf life was short like 3-4 years tops and the lube quality went way down-so now I use the Honda lube and really like it-the DuPont will be used on my garage door rollers--to answer the question all chemicals oil, paint, solvents, gas etc has a shelf life a lot has to do how it is stored- but to be sure if it's over a few years old it's best to call the company--they know--a friend of mine that had a M/C repair shop offered me a few cases of very expensive M/C oil but the shop closed 5 years ago- I said no thanks and that was hard to do- but why take a chance to save a few bucks
 

·
Registered
Joined
·
7,962 Posts
I recently cleaned my chain and sprockets then reapplied some castrol chain lube (spray). Left it on overnight. The next time I went for a ride I found my back wheel and exhaust are covered in chain muck. I didn't use much to begin with.. The spray can is about 5 years old, is that the issue? It's past its use by date? (nothing on the can though) :confused:
Perhaps some left over cleaner in the chain washed out your cold applied chain lube once it spun and warmed up... Your chain lube is fine. Just clean up and start over.
 
1 - 4 of 4 Posts
Top