Kawasaki Versys Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,517 Posts
Discussion Starter #1
My reset button has stopped working altogether. After reading all the posting on this I was going to fix it myself, if possible, but I'm still under warranty so I brought it to a dealer. They verified that it was defective and ordered a new cluster. However, I just got a call and the mechanic told me that Kawasaki told them to have me bring it in to the dealer and they will try to fix my unit in the shop. I think we all can guess where this is headed.:mad: Any way, I'll keep the masses informed and I'll take any suggestions you have.
 

·
Registered
Joined
·
207 Posts
This problem has popped up before. I have a theory and a possible fix for it. When I had the gauge cluster apart to fix the buzzing, I saw how the reset and select buttons work. When pushing the buttons, it is not a direct contact with the switch. Instead, it pushes against a very small piece of a plastic pin about 3/8" long that rides in a plastic tube. This is a very loose fit with a lot of slop and it may be getting cocked inside the plastic tube. The "drinking straw" repair method for eliminating the buzzing noise could also correct this by reducing the inside diameter of the tube and help to keep that plastic pin centered.
 

·
Registered
Joined
·
1,517 Posts
Discussion Starter #4
Brought it BACK to the dealer so they could verify that the little rubber rod under the rubber hood was contacting the switch on the circuit board. It was. (I had already taken it apart myself). They were busy and told me I had to leave the bike so I removed it myself and handed it to them.( I had the plastics off anyway), They are ordering me a new circuit board.
 
1 - 4 of 4 Posts
Top