Kawasaki Versys Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
I just bought a new Versys and tried adjusting the throttle- it had about a quarter inch of play. I couldn't get the adjuster or lock nut to move with my cold fingers so took pliers to them. I'm afraid I might have broken something here's a picture below. I can't re-screw the lock nut onto the bolt or can't get any adjustment to tighten my throttle response. Thoughts or help?
 

Attachments

·
Registered
Joined
·
16 Posts
If you are not able to screw the lock nut onto the bolt, then I think you had a part break. Shouldn't be too expensive to buy a new one. Good Luck!
 

·
Registered
Joined
·
18 Posts
Looks like you have a piece broke off in the throttle assembly. You will have to take it apart, remove the cable and back the broken piece out with a torx bit. Being plastic it should unscrew easily.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Looks like you have a piece broke off in the throttle assembly. You will have to take it apart, remove the cable and back the broken piece out with a torx bit. Being plastic it should unscrew easily.
What part is broken? Is there a picture of this piece anywhere so I can see what it's supposed to look like?
 

·
Premium Member
Joined
·
9,209 Posts
I just bought a new Versys and tried adjusting the throttle- it had about a quarter inch of play. I couldn't get the adjuster or lock nut to move with my cold fingers so took pliers to them. I'm afraid I might have broken something here's a picture below. I can't re-screw the lock nut onto the bolt or can't get any adjustment to tighten my throttle response. Thoughts or help?
Using this as a example with our motorcycle buddy that has nothing but problems with his new bike, possibly assembled my a newbie.
Notice both the jam nut and adjuster closest to the cable, the piece closest to the cable gets backed out of the housing, then the jam nut / ring locks it in place by tightening the ring to the housing, by your fingers. This is in the owners and service manual.
 

·
Registered
2013 v650
Joined
·
243 Posts
You will have to replace the cable. The adjustment end is broken. Get the service manual and see if you want to do it, or take it back to the dealer and try to get them to replace it under warranty.

Hope you got this fixed. I didn't look at the posting dates
 
1 - 9 of 9 Posts
Top