Kawasaki Versys Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
943 Posts
Discussion Starter #1 (Edited)
Picked up my X300 today and went for a ride

Couldn't get a ride to the dealer to pick up the new X-300, so I had to trailer the bike home.

And now, a little rant. What do they do for that "setup fee" ?

I can tell you what they don't do. Front tire 10 PSI rear tire 12 PSI. Radiator low, and overflow tank empty.

I checked most of the fasteners and then adjusted and lubed the chain and polished out some scratches. The windscreen must have been cleaned with Lemon Pledge and steel wool. Miraculously, got the majority of that polished out, as well.

Having not ever ridden one of these - I was pleasantly surprised. Took the little twisty 2-lane roads and never got over 50. Just riding easy for a bit of break-in. Made 80 miles in 50/sunny weather, and got home at dark.

More "testing" is necessary. :wink2:
.
.
.
Here we are at home, and then tucked into the basement with his other little friends.
.
.
.

 

·
Registered
Joined
·
112 Posts
nice, it looks right at home with the others. Any plans on farkling or accessories? Definitely shouldn't have to do those things on a new bike, that's part of the setup fee.
 

·
Registered
Joined
·
943 Posts
Discussion Starter #5
I have almost 15,000 miles on mine——-great bike. BTW, I live across the river from you in Waterloo, IL, and ride a lot in Missouri.

You bought the right color.
I'm in the big, booming metropolis of Villa Ridge, Missouri. That's about 15 miles west of Six Flags - just off of I-44 mile marker 251 (about 50 miles from Waterloo)

I see that you have the Shad side cases. What do you think about those ?
 
1 - 6 of 6 Posts
Top