Kawasaki Versys Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1,147 Posts
Discussion Starter #1
I've had two..count 'em TWO..power commaner 5 that didn't work straight out of the box...the first got sent back to DynaJet and replaced..with another FAILURE...Mind you this isn't due to some dumb error on my part..because I'm not putting it in...my mechanic was the top tuner for the Honda race team..and knows his way around power commanders (he's installed 1,000s)...My question would be..am I snake bit or what?? anyone else have this kind of problem with the pc5??? I am now waiting to contact DynaJet..it's the weekend after all..on this latest piece of garbage...they'd better start paying for the shipping and give me something less than another month wait like last time...faster shipping than snail mail would be greatly appreciated..but I'm not holding my breathe on either one...:mad::mad::mad:
 

·
Super Moderator
Joined
·
1,485 Posts
Yes I have one.
Yes I had a problem.
Yes I emailed them and they told me how to resolve the issue.
My Problem was solved.

Hope you solve your issues.

Now... what was the problem you were having?
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #3 (Edited)
Yes I have one.
Yes I had a problem.
Yes I emailed them and they told me how to resolve the issue.
My Problem was solved.

Hope you solve your issues.

Now... what was the problem you were having?
the first unit was just plain bad...the new one they sent..I can't say..as I am not the one installing it (if I remember right..information goes in ok..nothing comes out)...my mechanic will call DynaJet on Tuesday (you know mechanic's don't work on Mondays) and see if it the problem can't be worked out online...it took over a month to get a new unit out of them last time..I'm hoping it won't be that long this time...my mechanic is getting a little tired of this game too...a simple 1 hour job has turned into 4 or more now...AND I don't have my Versys this weekend..won't untill Tuesday sometime..with or without the PC5...:mad:
 

·
Super Moderator
Joined
·
1,485 Posts
My problems was not starting... my fix was to swap pins on PC5 connector so that Red PC5 wire matched the 12V+ of the OEM fuel injector harness(onmine it was afatter wire). Injectors have no polarity.
Check these wires.
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #5
sent your fix to my mechanic..as the 2nd commander didn't seem to be working and getting ahold of Dynajet was taking hours...if your fix doesn't work I will be bring the unit home and dealing with Dynajet personally...still :mad:
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #7
My problems was not starting... my fix was to swap pins on PC5 connector so that Red PC5 wire matched the 12V+ of the OEM fuel injector harness(onmine it was afatter wire). Injectors have no polarity.
Check these wires.
as mentioned..i sent this fix to my mechanic via email and it WORKED LIKE A CHARM...can't thank you enough for your help...if you ever get to the states i owe you a beer..hell i'll try and get you laid too... :D:cheers:
 

·
Super Moderator
Joined
·
1,485 Posts
Great news.

I don't know why mechanic was having an issue. I sent one email to Dynajet and got the answer the next day.

I too was surprised at the easy fix but why is it not part of the FAQs!

Enjoy the ride.
 

·
Registered
Joined
·
1,147 Posts
Discussion Starter #9
well there's been some correspondence between me..my mechanic..and dynojet...dynojet wants to blame Kawasaki..as if Kawwies wiring connectors change..are "inconsistant"...My mechanic DID get thru to them during the two install attempts..and both times they ran him thru..try this..try that...Never did they mention the wiring problems..which according to what I've heard..they knew about (I got the fix from Gigitt..see posts above..and he got it from dynojet)...Their last reply to my mechanic was "tuff luck" to him and me...Sent a us copy of their warranty...They did say they held a meeting and informed all of their techs..so hopefully no one else with a Versys will have to go thru these needless delays and problems...
having said all of that..it does seem to be working now and working well...noe if i hadn't bought that ditch last night all would be well...
 

·
Registered
Joined
·
200 Posts
Pc5

So, how do you like the performance of the PC5? Can you tell a big difference?

as mentioned..i sent this fix to my mechanic via email and it WORKED LIKE A CHARM...can't thank you enough for your help...if you ever get to the states i owe you a beer..hell i'll try and get you laid too... :D:cheers:
 
1 - 11 of 11 Posts
Top