Kawasaki Versys Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1 (Edited)
I've had it about 2 weeks now. Had 2700 miles on it when I got it at 3500 now. It's kawi green :smile2: and the only farkle that was on it when I got it was an SW-MOTECH Skid Plate. I've since added some trackside handguards
(which thankfully killed the "4k" buzz in my mirrors) and I've got some spool-sliders on the way that I hope will make chain maintenance easier. I did a clean/lube at ~2800 and an adjustment was also required and then again today at 3500.

I noticed 2 backfires, iirc they both were when rolling off throttle after a stretch of holding about 4.5k. Is this normal or could my FI system be beginning to trend to too rich?? Also my first 2 tanks of gas were 45.1 mpg but the last two were ~44 then 42.7... Hopefully just from letting the chain main't get away from me, I'd like to see it bounce back up after the chain service today. Is this typical?

Also, anyone know what the progression of things on the display is before running out of gas? I had it "yelling" at me once but haven't pushed it further than that yet.
 

·
Premium Member
Joined
·
7,815 Posts
:welcome:aboard and enjoy your ride - Be safe.

Backfiring is sort of normal but not excessive. You MPH looks normal and keep the tank filled:wink2:
 

·
Premium Member
Joined
·
9,119 Posts
I've had it about 2 weeks now. Had 2700 miles on it when I got it at 3500 now. It's kawi green :smile2: and the only farkle that was on it when I got it was an SW-MOTECH Skid Plate. I've since added some trackside handguards
(which thankfully killed the "4k" buzz in my mirrors) and I've got some spool-sliders on the way that I hope will make chain maintenance easier. I did a clean/lube at ~2800 and an adjustment was also required and then again today at 3500.

I noticed 2 backfires, iirc they both were when rolling off throttle after a stretch of holding about 4.5k. Is this normal or could my FI system be beginning to trend to too rich?? Also my first 2 tanks of gas were 45.1 mpg but the last two were ~44 then 42.7... Hopefully just from letting the chain main't get away from me, I'd like to see it bounce back up after the chain service today. Is this typical?

Also, anyone know what the progression of things on the display is before running out of gas? I had it "yelling" at me once but haven't pushed it further than that yet.
On the 2015 when it starts flashing I have about 100 KM left, on my 07, I think it was closer to 80 KM left, word of caution, the fuel pump is lubricated and cooled by the fuel, running out of fuel usually = a new fuel pump required. And yes there have been guys on this forum with a failed fuel pump. There is a aftermarket one available, info in How To Forum.
 

·
Super Moderator
Joined
·
19,176 Posts
:welcome: aboard!

...Hopefully just from letting the chain main't get away from me, I'd like to see it bounce back up after the chain service today. Is this typical?...
Possibly - I notice a BIG difference in how easy the rear wheel spins AFTER I oil my chain. - so that directly relates to WASTED horsepower when it's dirty (the chain...)!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
On the 2015 when it starts flashing I have about 100 KM left, on my 07, I think it was closer to 80 KM left, word of caution, the fuel pump is lubricated and cooled by the fuel, running out of fuel usually = a new fuel pump required. And yes there have been guys on this forum with a failed fuel pump. There is a aftermarket one available, info in How To Forum.
Thanks, good to know...
 

·
Registered
Joined
·
87 Posts
Ride and enjoy,I get 370km out of a full tank and I wont do more than 50km when flashing.
Ive got an 09 and love it.
Welcome from New Zealand.
 
1 - 10 of 10 Posts
Top