Kawasaki Versys Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, I'm new to this forum though I've had my Versys 650 for almost two years now.

It is a 2010/2010, black, and this week, I just noticed something weird going on.

There is a high pitch produced by the gas pump, you can hear it when idling, and when it is normal, it sounds steady and doesn't change the pitch.

This week I noticed the pitch is oscillating a LOT, and after a few rides, the lights started to dim along with the oscillation of the pitch.

First thing I thought of was the battery. Before I proceed, here are some facts on the bike:

- recently serviced it, cleaned everything, TBI, air filter, oiled everything. Came out as brand new.
- 20k km on it
- Battery was never changed - 4.5 years old now.
- Recently made a trip to some rocky and dusty roads.

That being said, I started off by checking battery with a multimeter:
engine off: steady 12.8V
ignition on, city lights on: dropped from 12.8V to 12.1V in less than a minute and then stabilized at it.
engine running, headlights on, city lights on: varying by large from 13V to 14V
engine running, all lights and horn on: no less than 12.8V reading.

I concluded the battery was holding on, though the oscillations measured above in the voltage happened along with the pitch variation and light dimm.

Checked alternator continuity, result OK.

I ordered a new battery, which hasn't arrived yet, because mine needs replacement anyway. But I'm rulling it out already.

I'm left with the following options:
- Gas pump clogged, drawing too much current, then dimming the lights.
- Some wires got corroded, pulling too much current, so on.
- Some connector got loose from rocky roads, too much current being sucked...
- Alternator going bad.
- Gas pump going bad.


I can't post on advanced forums yet because account is new, so I'm wondering if any of you have had this experience with oscillation on gas pump noise pitch.

From what I researched on this and other Kawasaki forums, people only complain about the noise being present, not oscillating or dimming the lights.
I also asked the same question at the FB Kawa Versys Group.

Any advice is welcome.

Thanks for letting me join the group.

Ride safe.

:feedback:
 

·
Registered
Joined
·
3,160 Posts
i would check your ground connections (and all the others wail your at it) and ten test your stator and rectifier
 
1 - 5 of 5 Posts
Top