Kawasaki Versys Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
There's a blade connector above my radiator on the left side of the bike.:interesting: Is that used for powering accessories? I believe the wire has a white and blue color.
I can't find any references to this in the user manual or service manual.
:dgi:

I guess there's a ground somewhere nearby....I need to take a closer look...:guilty:
 

·
Registered
Joined
·
3,427 Posts
There's a blade connector above my radiator on the left side of the bike.:interesting: Is that used for powering accessories? I believe the wire has a white and blue color.
I can't find any references to this in the user manual or service manual.
:dgi:

I guess there's a ground somewhere nearby....I need to take a closer look...:guilty:
I'm not sure we're talking about the same thing or not, the blade connectors you can buy at the auto parts store to tap into existing wiring, should be avoided. The blade pierces the insulation to make a easy connection to existing wires. Every time I've ever used them they have become a source of problems. The blade makes a bad connection to being with that latter corrodes and causes a flaky connection. The don't handle high currents very well and tend to have a lot of resistance. IMO use solder if you want a reliable low resistance connection.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #5
Thanks for the info.
I tried googling, but my google-fu must suck.
I even tried searching the service manual.
:sorry:
 

·
Registered
Joined
·
1,044 Posts
I took RS's query to mean he was looking for a quad connector to the aux circuit, the one in that farkle thread and in the reference I gave him. He said he wasn't interested in just using automotive blade connectors. I figure someone has a source for the male side of that quad connector.

No worries.

Also, RS, the aux circuit is in the 2010-2011 service manual on a sticky in this forum, in an Appendix, pages 17-12 and 17-13...basically where I got the original info I posted in that first thread reference about the undocumented fuse on a 2010. (It was undocumented until the first 2010 service manuals started showing up.)
 
1 - 6 of 6 Posts
Top