Kawasaki Versys Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter #1
Good morning everyone

Finally found my buzzing source, it´s the instruments panel rubbing on something. So I have a few pieces of anti skid rubber to insert. How to properly disassemble the 2010 panel, is it just the pressure screws in front and on the side, or should I also remove the optics (or something else)?

thks in advance
 

·
Registered
Joined
·
35 Posts
Good morning everyone

Finally found my buzzing source, it´s the instruments panel rubbing on something. So I have a few pieces of anti skid rubber to insert. How to properly disassemble the 2010 panel, is it just the pressure screws in front and on the side, or should I also remove the optics (or something else)?

thks in advance

I noticed the same thing on mine (2010 also). I actually thought it was the windshield, and since I ordered a tall Givi windshield, I did not look into it yet. (still waiting for the delivery after 1 month...:mad:).

Anyway, I'll try a shim as well to see if it solves the problem (seems to be worse at around 6K rpm).
 

·
Registered
Joined
·
1,229 Posts
... mine (2010 also). ... I ordered a tall Givi windshield, ... (still waiting for the delivery after 1 month...:mad:).
A couple of days ago I was told that the 2010 V Givi windshields are still stuck in customs :(
.
 

·
Registered
Joined
·
295 Posts
Discussion Starter #6
A couple of days ago I was told that the 2010 V Givi windshields are still stuck in customs :(
.
yes its a bummer. same thing happens to me if I order something a little bit larger or weightier from the US.. unfortunately no commercial agreement between US and the EU, in the global world we live in its kinda stupid, but on the other hand every government does favor to the chinese businesses.. we´re doomed lolol
 

·
Registered
Joined
·
295 Posts
Discussion Starter #7
I noticed the same thing on mine (2010 also). I actually thought it was the windshield, and since I ordered a tall Givi windshield, I did not look into it yet. (still waiting for the delivery after 1 month...:mad:).

Anyway, I'll try a shim as well to see if it solves the problem (seems to be worse at around 6K rpm).
I do have the GIVI. Maybe the strain in the mounts causes a higher level of buzzes. this weekend i´ll look into it.

So I do have to disassemble the optics, correct? I was hoping not..
 
1 - 7 of 7 Posts
Top