Kawasaki Versys Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I have a Givi v46 mounted on my 2009 with the SW Motech hardware.

Long story short...its shakes! It's not going anywhere (aka falling off) but its constantly bouncing around a bit to the point where I hear it moving around even at low speeds.

I put locktite on every bolt and made sure everything is tight a secure. Even when stopped I can kind of lean the case around in different directions.

Anyone else have this issue? Is this just normal?
 

·
Registered
Joined
·
175 Posts
To clarify (because you mentioned locktite)... Is it the case on the givi plate that is loose or the givi plate bolted to your rear rack that is loose? If it is the case, just use some foan under it (between the Givi plat and the case) to dampen the loose case... Maybe you are missing the rubber grommets that help support the case when attached... I have 4 of them that some keep falling off when I remove my topcase from the Givi plate...
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
It's the case that is loose.

I have the rubber pieces in place. It seems to me like there is just room to move around the two mounting pieces and the buckle that holds it down from the rear.

Just seems like it shouldn't move as much as it does.
 

·
Registered
Joined
·
1,190 Posts
I have mine on a Givi rack, and when I try and move the case around on the rack the bike moves more than the case moves on the rack?
 

·
Registered
Joined
·
623 Posts
I have a givi case mounted on sw motech top rack and it's rock solid.

Maybe you should inspect your mounting plate very closely and also the bottom of the case for cracks.
 

·
Registered
Joined
·
4,762 Posts
Anyone else have this issue? Is this just normal?
Mine wiggles a little up front as well. Not really enough to bother me. If you look closely, it looks as if the two "knobs" if you will up front that you slide the case onto and they hook the bottom are slightly too tall. The rear buckle is tight and of no concern.

At some point, I plan on pulling off the two knobs on the front and removing a bit of material from the bottom surfaces of them and reinstall. I feel like they would then properly hold the case down tighter. Don't remove too much or you wont be able to get the case on at all without adding washers back under them. I placed a bit of an old T-Shirt between the case and the plate to add a little pressure to the case. Working fine for me.

:goodluck:
 

·
Registered
Joined
·
1,018 Posts
I have the same setup - OE (SW-Motech) rack with Givi plate and V46 bag.



It's solid, there is no movement between the bag, plate or rack.


Gustavo
 

·
Registered
Joined
·
82 Posts
I have the same Givi V46 top case mounted on the Givi hardware. Mine doesn't budge, it's solid.
 

·
Registered
Joined
·
254 Posts
What Capn Kirk said - i have the same set up - mine wiggles too. It is the knobs that are to tall.
It used to bother me, but after 1000's of miles, and being over loaded (+40lbs) plenty of times. I have come to the conclusion it isn't going anywhere.
I would prefer it didn't wiggle.
 

·
Registered
Joined
·
623 Posts
Mine is loose now too. It used to be completely solid.

It looks like the mounting plate is starting to give where the 2 front tabs slide in. As far as I can tell.
 

·
Registered
Joined
·
4,762 Posts
I took my "knobs" off the Givi mount and filed them down making them shorter. I took my time and took off .030" at a time. I had to remove .090" total off of each before the trunk slid in snug (Yours will vary). The Givi trunk has a very good fit now. Easy 30 minute job. Just go slow when removing material and try it a few times. If you remove too much, then you must shim with washers. :goodluck:

 

·
Registered
Joined
·
45 Posts
What Capn Kirk said - i have the same set up - mine wiggles too. It is the knobs that are to tall.
It used to bother me, but after 1000's of miles, and being over loaded (+40lbs) plenty of times. I have come to the conclusion it isn't going anywhere.
I would prefer it didn't wiggle.
They are both correct. Now I have a V46 mounted on a Givi rack on my Versys, and it is solid, however, I have a E55 mounted on the SW Motech hardware on my Concours, and it wiggled up front a lot! The mounting pins in the front that TT sent me were way too tall. Working with them through emails, they finally sent me the correct mounting pins which are much shorter in length. Although it didn't fix the issue 100% (as these too are a bit tall), it did fix the issue 95%, and I'm happy with that.

I don't know if you got yours from Twisted Throttle or not, but you may want to send them an email and see if they will send you the shorter pins.

Texas
 

·
Registered
Joined
·
63 Posts
With my other bike I used the SW-moto mount that used the pins and it always wobbled. On this bike I got the actual Givi rack and it does not use the pins and it is solid on the back.
 
1 - 15 of 15 Posts
Top