Kawasaki Versys Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
A big Texas "tip of the hat" to this Forum! My '08 w/19,500 miles began exhibiting a pulsating feel when I softly used the front brake. She didn't have it when I put her up for the winter about 4 months ago so I was surprised when she gave me that uncomfortable feeling.

I searched this Forum for "brake pulsating" and there it was. A recommendation for addressing this issue. Clean and ever so slightly lube the bobbins. Heck, I didn't even know I had bobbins till I read the post!

They were very, very tight (evidence by 2 busted knuckles and a pinched palm.) Even after a couple attempts and allowing time for the slight oil to take effect, they were still very tight.

This morning, I hit the Forum again and dug a little deeper. 2 Youtube videos were there showing a method using a bolt and nut to more easily turn the bobbin. Back to the garage I went. This method made it much easier to turn the bobbins, spray with brake cleaner then carefully give a small squirt of WD. I wiped everything down one last time with brake cleaner and headed out.

Pulsing gone!!!! I read that many were only able to solve this issue by replacing their rotors. I'm happy to report for my little girl, this seems to have done the trick. If I have to add this to my annual maintenance list, so be it. It's not that difficult.

Thanks forum contributors!
 

·
Super Moderator
Joined
·
1,485 Posts
Nice.

I did the same but it took about 500km of riding after the cleaning for most of the pulsating to go away.
There was many many emergency stops performed in this 500km period as I was doing my Learners and practicing for a Learner test.
I still have a faint pulsating but not like the bucking bronco I was riding before.
 
1 - 2 of 2 Posts
Top