Kawasaki Versys Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
178 Posts
Discussion Starter #1
My Radiator Fan was stuck, so I worked it back and forth, and it spins freely,and I put 12 volts to the fan motor, and the fan runs fine ,but on the dash,the warning light does not light up with the key on...should it? I was riding in stop and go traffic on a hot day the other day and I think the fan should have come on...it did not :mad: So could someone tell me where the Fan Relay is located on my 09... I checked the Fan Fuse and it's ok...Thanks...Suggestions?:dgi:
 

·
Registered
Joined
·
178 Posts
Discussion Starter #3
Thank you...

Your posting of pages has been very helpful stlee29 .:thanx: I will investigate and let you know what I find...I'm having trouble getting the codes to display on the dash...I touch the diagnostic wire to ground quickly 5 times in 2 seconds but don't see anything happening on the dash...?
 

·
Registered
Joined
·
7,983 Posts
It won't display codes if none are memorized. Current codes are displayed by grounding it once (and keeping it grounded with ignition on). Code 14 would indicate a problem with the water temperature sensor circuit... Are you sure it got hot enough to activate the fan?
Water temperature sensor removal/installation, output voltage inspection and resistance inspection procedures are on pages 129 and 130.
 

·
Registered
Joined
·
173 Posts
Any progress on this? :feedback:

Tomorrow I am digging in too, my fan stopped working yesterday- it spins by hand, but it doesn't kick in- discovered this when the fluid started to boil, without the warning light coming on...
 

·
Registered
Joined
·
178 Posts
Discussion Starter #7
Fan is Working Again...

Any progress on this? :feedback:

Tomorrow I am digging in too, my fan stopped working yesterday- it spins by hand, but it doesn't kick in- discovered this when the fluid started to boil, without the warning light coming on...
I took a chance and ordered a Coolant Temp Switch for $50 and installed it...and bingo...the fan works and cycles on and off perfectly now...also changed the fluid while I was in there...The sensor is really easy to change...Thanks guys for all your help...:goodluck:
 
1 - 7 of 7 Posts
Top