Kawasaki Versys Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
573 Posts
Discussion Starter #1
Im just wondering how all of your installations have gone and if anyone has needed to do any modifications?
 

·
Registered
Joined
·
1,255 Posts

·
Registered
Joined
·
81 Posts
yes, just put them on a couple of weeks ago. Right one went on perfectly, but the support strut on the left side was out of line by .5 inch or so. I don't have a welder or any way to accurately bend it, so I just bent it with a long set of vice-grip pliers to the approximate position. The engine case bolt barely would engage, and wouldn't fully seat, but I just snugged it down as far as it would go and am hoping there's nothing behind it that will leak. I LOVE cruising with them as forward pegs--really a good alternate position.
 

·
Registered
Joined
·
35 Posts
Simple Install

+1 on the comments by layne1663, above.
I just returned from my garage after doing the install in less than thirty minutes. I also had to bend the small support brackets in toward the engine case about 3/8ths of an inch to make them flush. I used a vise and large visegrip pliers to make the two bends on each bracket. Then they fit perfectly. I supported the engine with a motorcycle jack (I don't have a bottle jack as Don's photos show in his directions) and an eight inch long piece of 1"x2" hardwood, placed on one of the motorcycle jack's lift plates. The original bolts came out effortlessly and the new fasteners (with blue loctite) went in easily too.
The UPS delivery man just phoned me and said the foot pegs I had on order were placed in my rural mailbox. I'm on my way down the road to get them now.
I'm really looking forward to my ride up to the Laguna Seca Moto GP because the highway pegs will greatly improve my comfort on the long ride.
 

·
Registered
Joined
·
573 Posts
Discussion Starter #7
Well it looks like I am not nuts. My clitch side bracket also didn't fit. The small engine case bracket was too long on mine. I had a welder fill in the stock drilled hole that it came with and then filled until it fit,then I driled a new hole. Now it fits.

I really like having the pegs. When I get a chchance I'll post what pegs I used.
 

·
Registered
Joined
·
1,255 Posts
I'm truly sorry about the problem and I can't understand it. I have 2 Versys here that I used for fitting and both sides fit perfectly. One is lowered and the other is standard height so I tried them on both. I have 5 sets left and have tried each set on one of the bikes and still there is no problem. I can't see engine mount specs being off that much so I don't know what the probem might be but at least it was not insurmountable. Thanks for the update.
 
1 - 8 of 8 Posts
Top