Kawasaki Versys Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
I have problem with my V. Since yesterday when I start the bike on cold engine the rpm arrow is getting crazy -its going from 1k to 2k there and back. All lasts till engine gets warm- later its 1k rpm like it always was.

Idk if its matter of my Arrow exhaust(earlier on same was working fine) or fuel or maybe can be something else?
please help;)
 

·
Registered
Joined
·
7,982 Posts
You have an oxygen sensor on your exhaust? Does the FI lamp stay on or flash? How many kms are on your Versys and spark plugs? What kind of gasoline do you use? Have you checked your throttle body synchronization (vacuum balance)? Normal warmed up idle should be set to 1300 rpm.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3
Yep got the sensor, FI lamp is off, i have 18k km, spark plugs were changed 10k km ago or so, was 98 octane fuel, didnt check vacuum...ok maybe it is 1,3k rpm, but im more scared bout those crazy movements on cold engine...
 

·
Registered
Joined
·
10 Posts
Sorry for bringing this topic up, but I have the same problem for quite some time and was wondering if you solved it?

The symptoms I'm having are pretty much the same and it happens only during the engine warming up period.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
you have stock exhaust or sth else?
if you swaped exhaust to other its normal and you dont have anything to worry about... maybe PC would help but its not worth money
that rpm waving doesnt cause any damage to engine so dont worry- just ride;)))
 
1 - 6 of 6 Posts
Top