Kawasaki Versys Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
The second set of SW Motech bars came in today. The first set must have been a manufacturer's defect. The second set bolted up perfectly in about 30 minutes. I just have to torque the bolts and put the plastics back on. I'm pleased that Twisted Throttle worked with me on this. I will let them know it all worked out tomorrow. :thumb:
 

·
Registered
Joined
·
774 Posts
And tell them not to send the first set back out to somebody else.

Good to hear they actually fit correctly when they are made that way.
 

·
Registered
Joined
·
48 Posts
I'm also glad the 2nd set went on well. Any feedback about the "vibration issues" others have spoken of with the SW engine guards?
 

·
Registered
Joined
·
181 Posts
The second set of SW Motech bars came in today. The first set must have been a manufacturer's defect. The second set bolted up perfectly in about 30 minutes. I just have to torque the bolts and put the plastics back on. I'm pleased that Twisted Throttle worked with me on this. I will let them know it all worked out tomorrow. :thumb:
Did you have to send the first set back before they sent you the second set? I've still got my original, mis-aligned set on, and it's 'good enough', but if they'll send a second set so I can just swap them and not have to put the stock parts back on for a week, it'd be worth my while...
 

·
Registered
Joined
·
266 Posts
Discussion Starter #6
Did you have to send the first set back before they sent you the second set? I've still got my original, mis-aligned set on, and it's 'good enough', but if they'll send a second set so I can just swap them and not have to put the stock parts back on for a week, it'd be worth my while...
They sent the second set when the saw the first set was on the way back. They sent me a shipping label. I'm very pleased. I have a 2011 with the EPA can, and all I needed to do was push it behind the top of the crashbar and it bolted right back into place. :thumb:
 

·
Registered
Joined
·
293 Posts
The second set of SW Motech bars came in today. The first set must have been a manufacturer's defect. The second set bolted up perfectly in about 30 minutes. I just have to torque the bolts and put the plastics back on. I'm pleased that Twisted Throttle worked with me on this. I will let them know it all worked out tomorrow. :thumb:
Tony -- Do you have a 2010-2012 model, or the 07-09 model? Just wondering because I am interested in getting a set of crash bars that are solid and easy to install. Let me know if you can :)
 

·
Registered
Joined
·
266 Posts
Discussion Starter #8
Tony -- Do you have a 2010-2012 model, or the 07-09 model? Just wondering because I am interested in getting a set of crash bars that are solid and easy to install. Let me know if you can :)
I have a 2011. I took it for a ride today to see if anything would fall off. Nothing did and no vibrations were noted. :D
 

·
Registered
Joined
·
266 Posts
Discussion Starter #9
Here's a couple pictures of the bars on the bike. I didn't have a problem with the EPA can. I just pushed it behind the the upper mount on the bars and the cover bolted right back on. I took it for a ride and no vibration was noted.



 
1 - 9 of 9 Posts
Top