Kawasaki Versys Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a problem where my engine wont rev out when the bike is first started and the engine is cold. Has anyone else experienced this? Any ideas of what the issue could be? One things warm up everything is fine.

Thanks.
 

·
Registered
Joined
·
79 Posts
Never had this. Sounds electrical. If you open the throttle and nothing happens then either the throttle isn't opening, which isn't your case cuz it opens later, or the open throttle is not generating more fuel, which would be electrical somehow. Some people here are fuel injection experts, not me.

My issue is that the cold idle is too variable. Sometimes high to 2,000. Sometimes nothing. Sometimes high then low then high. Something is not right with the cold idle but the manual says nothing about lubing or greasing any of those mechanisms.
 

·
Registered
Joined
·
8,000 Posts
I have a problem where my engine wont rev out when the bike is first started and the engine is cold. Has anyone else experienced this? Any ideas of what the issue could be? One things warm up everything is fine.

Thanks.
You mean it's hard to drive off right after idle is down to normal?

Year, mileage, maintenance? Is your normal warmed up idle set to 1,300 rpm?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
You mean it's hard to drive off right after idle is down to normal?

Year, mileage, maintenance? Is your normal warmed up idle set to 1,300 rpm?
Invader

Yes, it is very hard to drive off after it idles down. It generally lasts for a 1km or so. It feels like it is not getting fuel at wide open throttle. Once you back off to 1/4 throttle or so it kicks back in.

2007 19000km regular maintenance.
 
1 - 6 of 6 Posts
Top