Kawasaki Versys Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1
Just replaced my clutch cable in about 15 minutes , I didnt re route it and gave it lots of lube . old cable was frayed down to 2 strands at the lever , the guy at Kawasaki said its a common problem . thanks for all the advice guys . this forum is great !!! . I am new to motorcycles and shudder to think what would happen if a clutch cable broke suddenly at a traffic light .:thanx:
 

·
Super Moderator
Joined
·
19,780 Posts
Just replaced my clutch cable in about 15 minutes , I didnt re route it and gave it lots of lube . old cable was frayed down to 2 strands at the lever , the guy at Kawasaki said its a common problem . thanks for all the advice guys . this forum is great !!! . I am new to motorcycles and shudder to think what would happen if a clutch cable broke suddenly at a traffic light .:thanx:
I've posted into a few threads about how to PROPERLY adjust your cable (NOT the way they come from the dealers...). MINE is original (in my '08) with 42,800 miles.
 

·
Registered
Joined
·
186 Posts
At the risk of sounding crazy... I haven't lubed my cable once since Ive owned the bike, its been a year and 8000 miles, no problems. I have a spare with me at all times, but I'm experimenting and seeing how long this will last.
 

·
Registered
Joined
·
575 Posts
Just changed mine at 72,000 klms. The factory cable was a little tight but no unusual wear at all. Could have kept it but a spare under the seat makes me feel better. Regular maintenance sure pays off.
 
1 - 5 of 5 Posts
Top