Kawasaki Versys Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Probably a dumb question, I have had my Versys for nearly two weeks now, and loving it. Now I have a buzzing noise coming from the front somewhere when it gets to 3000rpm and stops when i get to about 80 or 90 km/h, I've tightened the windshield screws, and have been told it's air going through the holes in front discs or vibration of the little bits of fairing sitting under the windshield. Never had this until now. Bloody annoying.

Just wondering if anyone else has had or heard this on theirs.
 

·
Registered
Joined
·
14 Posts
Buzzing

Search the forum for the word "buzzing" and you will find what you need to know. It's mainly the tabs above the headlight.
 

·
Registered
Joined
·
108 Posts
holly ****. i have the same problem. it is very annoying. I thought it was the windshield and i tightened the windshield screws but it is still there. did you guys find anything else that might be it?
 

·
Registered
Joined
·
38 Posts
for me it was the black housing just aboce the spedometer. you can identify this by simply placing your hand on it and pushing down when the noise is hapening.

I took some sort of weather striping or some other form of all purpose/all weather foam would work great. just place it between the spedo and the black plastic
 

·
Registered
Joined
·
21 Posts
There is actually two sources of buzzing, but the both come from around the same area.

When I first got mine there was a loud buzz, and it was fixed by putting some foam weatherstripping under the fairing area where the plastic dash housing meets the back of the headlight area.

The second buzzing from the dash is the vibration of the plastic speedo housing. It is not as loud and for me it actually just started to be noticeable. Another piece of weatherstripping should do the job.
 

·
Registered
Joined
·
387 Posts
Got my first buzzing this weekend at low RPM's. Couldn't figure it out; RE-READ all the forum info... then tonight found out it was a loose screw on my Givi windscreen causing the plastic to rattle. Duh...

Tighten those screws!!
 

·
Registered
Joined
·
530 Posts
Tips of the fairing above the headlight - drill out the holes so the fairing tips sit flush.

Re-route your clutch cable - it's bound up in there pretty tight. After I rerouted mine - I got rid of more of the buzzing.

Foam weather strip tape on all areas where fairings/plastic bits meet. This one's been mentioned.

I also found the color panels under the seat by the rear tire had loose plastic pop-connectors. I replaced them with proper screws and I also put more weather stripping where the frame contact those color panels on the inside. They are much more secure now.

I found the black plastic panels where your knees touch under the tank are loose - I need to find some rubber and build that up so they don't bend so much when I press my knees against them.
 

·
Registered
Joined
·
5 Posts
I also found the color panels under the seat by the rear tire had loose plastic pop-connectors. I replaced them with proper screws and I also put more weather stripping where the frame contact those color panels on the inside. They are much more secure now.

I found the black plastic panels where your knees touch under the tank are loose - I need to find some rubber and build that up so they don't bend so much when I press my knees against them.
For the former, I found the plastic on the left under the seat to be really loose the first day I had the bike. I haven't looked into securing them yet so I may feel stupid for asking this when I get home and actually look at it, but how did you go about replacing the pop-connectors with screws?

I haven't found the later problem yet, is it a recent issue you found?
 

·
Registered
Joined
·
530 Posts
For the former, I found the plastic on the left under the seat to be really loose the first day I had the bike. I haven't looked into securing them yet so I may feel stupid for asking this when I get home and actually look at it, but how did you go about replacing the pop-connectors with screws?

I haven't found the later problem yet, is it a recent issue you found?
On the first part - I just used machine screws with nylon lock washers to replace those black plast pop-connectors. Then if you look straigt down from where those pop-connectors are - you'll see a metal part of the frame touches the plastic color panel on the inside. Mine actually had rubbing marks and this was just after a few days of owning the bike. I put foam double sided tap on that, left the top tape backing in place and reinstalled. Now the color panels are secure. I'll have to post some pics.

On the front panels by your knees - that's a new one that I discovered. I feel I slide around too much on hard stops - I want to install pads on the side to keep me in place. I got to looking at those black plastic panels under the tank and realized they bend very easilly. I need something solid there to lock my knees to. I plan to beef this up and add those pads.
 

·
Registered
Joined
·
144 Posts
buzzing

Mine did the same thing. When I took it in for the first service the other day I told the service guy to ride it and listen. This seems to be a common problem. What he did was call Kawasaki to confirm it. The speedo and rpm console is the buzz. My service tech put some black foam rubber around it. The buzzing has stopped. Fairly simple.
 

·
Registered
Joined
·
80 Posts
Buzz Kill

Here's my solution. I don't know how long it will last. We'll see!

I got some new foam tape from the hardware store. I added it over the existing "damper" foam above the headlight and under the lip of the cowling that fits above the headlight.

The new foam is much thicker and will protrude from the joint unless you trim it off with a razorblade.

I also replaced the plastic rivets which hold the cowling in place. I used some M6 button head screws and nylocks. I also fitted some rubber washers between the parts.

See the attached. Enjoy!
 

Attachments

·
Registered
Joined
·
19 Posts
I got "the buzz" on my first lap around the block. Firs I thought to be somewhere on the radiator. Later on I found out that it was coming from the front brake pads case. Closed inspection turn out nothing. I thought then that the break pads where rattling. I checked by braking in the middle of the buzz and indeed, it stopped but came back right after release. After 2 days using the brakes the buzz vanished.
 

·
Registered
Joined
·
27 Posts
Ah the good old parallel twin...vibrations galore. Makes ya feel like you're riding a real bike though doesn't it. Alphebitsoups got it. That was exactly where my buzz was coming from.
 

·
Registered
Joined
·
4 Posts
Hey, thanks for the tip. I did your fix today and the buzz is gone. The previous owner told me it was caused by the Givi windscreen, so I swapped the original back on, still buzzed. Then I saw your fix and that worked.

Cheers from a new Versys owner!

Tim
 
1 - 18 of 18 Posts
Top