Kawasaki Versys Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello everyone,
Since I bought the bike (new), which has happened to me a few times, when going from 5th to 6th, the selector locks, and immediately after it disengages the gear, getting into a "false" neutral. I think it's an electronic problem, because as using the clutch it works perfectly.
I've been complaining for about 18 months now and they don't solve my problem... I'm getting fed up. Has anyone ever had a similar problem?
 

· Registered
Joined
·
1,483 Posts
Just disable the QS. I have an older model, and fitted recently the Healtech QS, and after a short time, I took it off. The gearbox in Versys 1000 is soooo smooth. QS can only make it worse. I do clutchless shifting even from 1st to 2n gear and it is effortless without any clunk.
 

· Registered
Joined
·
359 Posts
When I first got got my 2019SE+ I occasionally had trouble getting into the next gear - turns out I was inadvertently keeping a slight amount of upward pressure on the shifter. That is easy to do because of how light of a force is required on the shifter. The other issue with QS is the clunking sometimes heard during the shift. Don't recall a false neutral issue. Usually the 5-6 QS is the smoothest shift. Don't let this go, sounds like a real issue.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top