Kawasaki Versys Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
2018 650 SE

Since new my bike does what sounds like a backfire on deceleration. Not all the time. I would say approx 10% of the time. Always when rev-matching on deceleration going from 3rd to 2nd. Once in a while from 4th to 3rd. The bike runs flawlessly besides that. I bought the bike about 2 1/2 weeks ago and now have almost 2900 kms on it and it has done it since the 1st ride home. Do you think it is because they are set so lean because of emissions?
 

·
Premium Member
Joined
·
16,150 Posts
+1 on the exhaust leak. Easy way to check for leaks is to take a lit cigarette and pass it close to where the exhaust connects while the engine is running. If there is a leak you will see the smoke from the cigarette go into the spot of the leak...
 

·
Registered
Joined
·
363 Posts
It its a loud backfire +1 on the leak. If it is just some popping, that is just the PAIR valve and is normal (though not too noticable with stock exhaust).
 

·
Registered
Joined
·
308 Posts
Is it backfiring or afterfiring--backfiring is though the intake-afterfiring through the exhaust-makes a difference-the main cause of both is a lean mixture-and or an air leak
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
It does it about 10% of the time when I am downshifting and Rev-Matching. Example....I am in 3rd going to 2nd. Pull in Clutch and Give a quick shot of throttle to match engine speeds with rear wheel but instead it backfires / sputters once in a while when doing this. Makes a loud Pop or backfire, not sure which it is. Sometimes it just chokes and gags. Not often just once in a while. Almost always in 3rd to 2nd, but occasionally from 4th to 3rd.
 

·
Registered
Joined
·
141 Posts
My 2009 Versys makes a "popping" sound when I do similar with the throttle and downshifting. It only seems to make one or two "pop" noises and then continues as it should. Every once in a while I can get it to do it when I just rev the engine, but normally it only happens during a gearshift. I just assumed it was normal or maybe my air filter is clogged as I've never cleaned/changed it so I might be running rich instead of lean.

Edit:I've had the bike for about 8 months and put just over 3000 miles on it. It had 16464 when I first got it.
 

·
Registered
Joined
·
38 Posts
So it sounds like when you are trying to rev match for downshifts when you blip the throttle, instead of it revving, it kind of pops and sputters. I had mine do that once, it was alarming. Are you downshifting pretty conservatively? As in, are you carrying the current gear to a pretty low RPM before you downshift to the next one? I'd also think in this case as a shot in the dark, maybe check your air filter and make sure it's seated properly?
 

·
Registered
Joined
·
141 Posts
So it sounds like when you are trying to rev match for downshifts when you blip the throttle, instead of it revving, it kind of pops and sputters. I had mine do that once, it was alarming. Are you downshifting pretty conservatively? As in, are you carrying the current gear to a pretty low RPM before you downshift to the next one? I'd also think in this case as a shot in the dark, maybe check your air filter and make sure it's seated properly?
I think you are describing what I am doing. Thanks for the explanation. Air filter is on the list of things to do soon anyway.

Didn't mean to hijack thread, but I had similar experience to OP. Like most things, its just me panicking because I'm not riding "correctly".
 

·
Premium Member
Joined
·
9,109 Posts
Warranty

If the 18 is anything like the 15, I wouldn't be surprised to find the airbox not seated properly. My 15 , the airbox almost had to be pried out due to the tight wiring harness, this sits on a angle so very easy to appear mounted correctly when it isn't. I used about 8 of the 100 LB black wire ties to pull my harness back to the frame, now the airbox is easy to remove. And air bypassing this could be the root cause. Only way I know of to check this is removing the gas tank.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #12
So it sounds like when you are trying to rev match for downshifts when you blip the throttle, instead of it revving, it kind of pops and sputters. I had mine do that once, it was alarming. Are you downshifting pretty conservatively? As in, are you carrying the current gear to a pretty low RPM before you downshift to the next one? I'd also think in this case as a shot in the dark, maybe check your air filter and make sure it's seated properly?
Now that you mention it, it does seem to do it when I am doing "Conservative" downshifts. Never does it on higher RPM downshifts. And just to clarify. It is never doing it when the transmission is engaged, only when clutch is disengaged and I go to Blip the throttle, does is do the firecraker sound or bog / gag a bit. So technically not on deceleration. I will do some further experimentation.
 
1 - 12 of 12 Posts
Top