Kawasaki Versys Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I am from Australia with a 2011 Kawasaki Ninja 250R, I have just installed all new indicators which were bought online from overseas.
But for some reason the left or right indicators aren't flashing when I indicate to the left or right, all the indicators just turn on and stay on.

Anyone know what might have happened? and how i can fix this?
 

·
Registered
Joined
·
7,979 Posts
Did you get LED lamps instead of incadescent like the originals?

LED brake/tail lamps will not flash with thermal flasher units due to their extremely low current draw. Also, with stock flasher units, the turn signals may flash faster than normal (Hyper-Flash). These installations will require an electronic flasher unit. Often, HEAVY DUTY flasher relays will also work with LED bulbs. Try to find flashers designed to work with LED bulbs, they will say "LED Compatible".
Another fix is the installation of Load Resistors which are wired across (in parallel with) the turn signal bulbs to simulate the load of a standard filament bulb.

Scroll down for Electronic LED Flashers, and Load Resistor Kits: http://www.superbrightleds.com/cgi-bin/store/index.cgi?action=DispPage&Page2Disp=/tail-brake-turn.html#flasher

Motorcycle electronic flasher # LF1-S-FLAT ($8.95) could be installed by cutting off connector and splicing wires. Stock flasher relay is up on the left of headlight, under fairing.

http://www.superbrightleds.com/cgi-bin/store/index.cgi?action=DispPage&Page2Disp=/flashers.htm
 
1 - 2 of 2 Posts
Top