Done with pioneer - Kawasaki Versys Forum
Off Topic Discussions For all of your off topic talk and just general B.S. Jokes, funny stories, etc...

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-30-2009, 08:10 PM Thread Starter
Member
 
versysred's Avatar
 
Join Date: Sep 2008
Location: Bridgeton, NJ
Posts: 304
Mentioned: 0 Post(s)
Send a message via AIM to versysred Send a message via Yahoo to versysred
Angry Done with pioneer

Alright I need to vent and also throw some info out there. I do not mind if you have had no problems with your pioneer or that you swear by them. Here is what I have to say.

Started out installing car audio back in like 1998 installed my first system in a 1996 Honda civic. The head unit was a pioneer 9800 I believe. 3 months after the install was done the cd stopped ejecting. It was under warranty so it was sent in, they found nothing wrong with it. Put it back in 4 weeks later the same thing but we still kept it. It was junk. Second one was in a buddy's VW the face plate was faulty, sent it back the new one the internal amp failed after 2 days of use. I get my very first car I install a pioneer deck. Wining alternator noise threw the speakers like crazy, and it just didn't work right. So I sent it back and got a alpine installed it not one hint of any problems ever. In 2008 I did a double din install for a guy and the unit never worked right and never allowed you to watch videos even with the proper parking brake bypass. So fast forward to 2009. I decide to give pioneer another chance with there premier lineup. So I trade a guy for a Premier Pioneer P880PRS. Worked fine except that wining noise was back. So a guy wanted to trade for a alpine deck I was all for it. So I sent mine to him very well packed and in perfect working condition. He gets it the thing overheats and the cd dose not eject all the way. I just talked to a few installers and the cd problem is very common on all pioneer decks. Pioneer has lost there touch and tehre quality as well. So I am done with them anyone wants to ask me about them I am going to tell them straight up there junk and I will never own another thing from them for as long as I am installing them in my car. They are junk and my choice is Alpine.
versysred is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-30-2009, 09:17 PM
Member
 
Bear on a bicycle's Avatar
 
Join Date: Mar 2008
Location: Converse, Tx
Posts: 4,695
Mentioned: 0 Post(s)
Good rant!!

Replaced a 2 year old alpine that was AFU with a pioneer back in early 2000 time frame. That pioneer is now in a home-made redneck jam box, still going strong. The thing I HATE about pioneer & the reason it's not in my car is the stupid random play & the tiny little buttons.

The alpine started out doing weird things like, turn the volume up, it would go down. Then, it developed into, press a preset, the volume would change, or it would adjust the bass, random crap like that. Then the display started going in & out, so I replaced it with the pioneer. The radio was for the wife's car, so she picked it. She liked it a lot & it stayed in her car until we traded it off a few years later. I kept the pioneer, installing the original radio back in the car before trading it in. Of course, this is the only pioneer I've owned, at least that I can remember.

Let me also say, I'm not an installer by trade, I do it as a hobby. I've helped a lot of friends & family put stereos in their cars & homes over the years. I've seen a few lemons & I've had a few surprise me, like my old aiwa.



Bear on a bicycle is offline  
post #3 of 5 (permalink) Old 08-30-2009, 09:53 PM Thread Starter
Member
 
versysred's Avatar
 
Join Date: Sep 2008
Location: Bridgeton, NJ
Posts: 304
Mentioned: 0 Post(s)
Send a message via AIM to versysred Send a message via Yahoo to versysred
Ya some earlier models still work fine but they have slowly been going down hill as the audio industry has seen from them. I have to say that I have switched to alpine and never had a problem again. My friends have done the same. I understand what you are saying though.
versysred is offline  
post #4 of 5 (permalink) Old 08-30-2009, 11:59 PM
Member
 
cabrown's Avatar
 
Join Date: Mar 2009
Location: Jesup, IA
Posts: 41
Mentioned: 0 Post(s)
I've owned or installed just about anything, and I've always been fond of Clarion.

Sarcasm is a privilege.......not a right.

08 Versys....1st bike and love it!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
cabrown is offline  
post #5 of 5 (permalink) Old 08-31-2009, 01:48 PM Thread Starter
Member
 
versysred's Avatar
 
Join Date: Sep 2008
Location: Bridgeton, NJ
Posts: 304
Mentioned: 0 Post(s)
Send a message via AIM to versysred Send a message via Yahoo to versysred
They have a few SQ head units but all of them are ugly IMO. lol
versysred is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome