Friends Versys led turn signal problems - Kawasaki Versys Forum
Member Introductions Just joined? Tell us about yourself and your ride.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-08-2015, 10:55 PM Thread Starter
Member
 
Join Date: May 2015
Posts: 1
Mentioned: 0 Post(s)
Friends Versys led turn signal problems

So a buddy got some LED turn signal mirrors for his bike.

I put LED strips in my headlights that are tied to my turn signals in series, they flash just fine and both run. but the previous owner but my flush mount signals in and now im not sure if they are LED or bulb.

because i tried to put the versys LED mirrors in series with their turn signal and i have 2 problems. The LEDs blink twice speed, and the regular turn signal bulb never lights up.

Is it possible to wire the LED mirror in series with the front left turn signal bulb and have them both run? Is there a reason why the bulb is not running and the LEDs are? If both are in series then they should get the same current, and there isn't that much of a voltage drop for the bulbs....

Any ideas? friend wants lights working tomorrow which means NAPA parts and elbow grease.
caedo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-09-2015, 03:03 AM
Super Moderator
 
Join Date: Dec 2013
Location: Sydney Australia
Posts: 1,463
Mentioned: 6 Post(s)
Garage
You wired it wrong. connect parallel to original bulb turn signal.

The LED uses less current and the relay cannot blink correctly. Sounds like LED is connected and original Turn bulb is disconnected.

Blinker: + positive wire, E earth wire
---+
---E

Blinker and LED
---+---+
---E---E

Series is:
---+---E---+---E
Gigitt is offline  
post #3 of 3 (permalink) Old 05-10-2015, 05:02 PM
Super Moderator
 
fasteddiecopeman's Avatar
 
Join Date: Jul 2008
Location: Kelowna, BC - summer; Florence, AZ - winter
Posts: 18,373
Mentioned: 33 Post(s)
I know NOTHING about electrics, but when I put the LED lights on my aluminum panniers, I just 'added' them to the wires for my stock rear sigs (parallel...?), and everything flashes normally, as the stock resistance is still there w/ the stock bulbs.

Ed
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'08 V AZ, '15 V650LT BC
Ride to D2D 2013, June '13

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2015, June '15

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2016, June '16

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
fasteddiecopeman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome