Rpm indicator acting weird - Kawasaki Versys Forum
Member Introductions Just joined? Tell us about yourself and your ride.

Like Tree4Likes
  • 2 Post By janda.m
  • 2 Post By fasteddiecopeman
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 03-18-2020, 01:54 PM Thread Starter
Member
 
Join Date: Feb 2020
Posts: 4
Mentioned: 0 Post(s)
Rpm indicator acting weird

Can anyone help me with this issue? https://youtu.be/8pWJjHGsQz4
My bike is MKII 2010 with 52000km... From bottom to 4,500 rpm the Indicator jams.. From 4, 500rpm is smooth.. Its doing more than a year but now it is more often... Chain and sprockets are brand new.. Oil changed...speed sensor cleaned... Bought new spark plugs and
want to do vacuum sync on few days... I looked for kined wires and connectors but didn't find anything wrong so far... Thx
janda.m is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-18-2020, 06:35 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 7,928
Mentioned: 46 Post(s)
Welcome From Canada

onewizard is offline  
post #3 of 15 (permalink) Old 03-18-2020, 06:37 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 7,928
Mentioned: 46 Post(s)
Need a Second post

First until we get people back in administration ( requesting a change to one post and 24 hours) , you need a second post and 48 hours from that. Several areas are off limits to you. I am sending a PM to you.
onewizard is offline  
 
post #4 of 15 (permalink) Old 03-18-2020, 10:56 PM
Super Moderator
 
Fastoman's Avatar
 
Join Date: Sep 2009
Location: Ipoh.Perak.Malaysia
Posts: 7,327
Mentioned: 8 Post(s)
aboard.
Fastoman is offline  
post #5 of 15 (permalink) Old 03-19-2020, 01:01 AM Thread Starter
Member
 
Join Date: Feb 2020
Posts: 4
Mentioned: 0 Post(s)
This is very weird rules
janda.m is offline  
post #6 of 15 (permalink) Old 03-19-2020, 05:50 AM
Super Moderator
 
Fastoman's Avatar
 
Join Date: Sep 2009
Location: Ipoh.Perak.Malaysia
Posts: 7,327
Mentioned: 8 Post(s)
Quote:
Originally Posted by janda.m View Post
This is very weird rules
you done with your second post. I pin my take on the speed sensor for you meter problem. Check wiring and speed sensor.
Fastoman is offline  
post #7 of 15 (permalink) Old 03-19-2020, 12:15 PM Thread Starter
Member
 
Join Date: Feb 2020
Posts: 4
Mentioned: 0 Post(s)
Update... Now the Indicator works a while and stay stuck at 4500 rpms... Only way to set it down is a strong tap on the screen...

Wiring checked... I want to squeeze female pins maybe they are a bit loose due to vibrations... If the speed sensor is faulty it won't show the speed either did he?... What sensor is related to rpms? Speed sensor or crankshaft sensor? When in neutral only thing what spin is crankshaft so my guess it is crankshaft sensor 😕
janda.m is offline  
post #8 of 15 (permalink) Old 03-19-2020, 04:13 PM
Super Moderator
 
fasteddiecopeman's Avatar
 
Join Date: Jul 2008
Location: Kelowna, BC - summer; Florence, AZ - winter
Posts: 18,400
Mentioned: 34 Post(s)
aboard!

Ed
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'08 V AZ, '15 V650LT BC
Ride to D2D 2013, June '13

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2015, June '15

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2016, June '16

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
fasteddiecopeman is offline  
post #9 of 15 (permalink) Old 03-19-2020, 06:44 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 7,928
Mentioned: 46 Post(s)
Quote:
Originally Posted by janda.m View Post
Update... Now the Indicator works a while and stay stuck at 4500 rpms... Only way to set it down is a strong tap on the screen...

Wiring checked... I want to squeeze female pins maybe they are a bit loose due to vibrations... If the speed sensor is faulty it won't show the speed either did he?... What sensor is related to rpms? Speed sensor or crankshaft sensor? When in neutral only thing what spin is crankshaft so my guess it is crankshaft sensor 😕
possibly more than one problem, that sensor is vulnerable to damage. There is s test in the manual for that . be aware on the MK-1 and MK-2 , some connectors were prone to corrosion , that is one of them, however your motor would run like crap because the ECU drives the display. There are posts on taking the display apart, many experienced problems with the reset button and clock button.

https://www.kawasakiversys.com/forum...pg-km-l-2.html
onewizard is offline  
post #10 of 15 (permalink) Old 03-19-2020, 11:52 PM
Member
 
silviefox's Avatar
 
Join Date: Aug 2014
Location: welches, oregon
Posts: 3,148
Mentioned: 5 Post(s)
Garage
Send a message via Skype™ to silviefox
i left a coment on your vid. check thaat. im going to go pass out now. yay boooooze...zzzzZZZZzzzzz

yes im a guy.
Silvie=latin for. Of the forest /woods. Fox= Vulpine (also my middle name)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

"closed mindedness causes bliss in simple minded people"
silviefox is offline  
post #11 of 15 (permalink) Old 03-20-2020, 12:28 PM Thread Starter
Member
 
Join Date: Feb 2020
Posts: 4
Mentioned: 0 Post(s)
I think I solved that out... I took apart the whole cluster.. Poped out the Indicator and used wd40... Putted everything together and now its moving smooth 😁
onewizard and Fastoman like this.
janda.m is offline  
post #12 of 15 (permalink) Old 03-20-2020, 08:47 PM
Member
 
jaaklucas's Avatar
 
Join Date: Feb 2016
Location: Vancouver B.C.
Posts: 469
Mentioned: 3 Post(s)
Quote:
Originally Posted by silviefox View Post
i left a coment on your vid. check thaat. im going to go pass out now. yay boooooze...zzzzZZZZzzzzz
siviefox,I know were supposed to self-distance ourselves in this pandemic but I didnt know we were supposed to self-medicate!
jaaklucas is offline  
post #13 of 15 (permalink) Old 03-21-2020, 10:29 AM
Member
 
Join Date: Oct 2016
Location: mid Flowriduh
Posts: 696
Mentioned: 2 Post(s)
Quote:
Originally Posted by jaaklucas View Post
siviefox,I know were supposed to self-distance ourselves in this pandemic but I didnt know we were supposed to self-medicate!
It's good thing you're hanging out on this forum to learn the important stuff.

Glad to hear the OP has the problem licked.

Ride Focused.

Yeah, if you want true ram air tuning, you better be willing to ram some air! (SteveinSunnyFlorida)

'15 KLE650LT
'99 Concours(with 234,xxx miles on it), sold
'98 KLR650


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


And most of Canada too, eh?
SteveJ is offline  
post #14 of 15 (permalink) Old 03-24-2020, 06:11 PM
Member
 
silviefox's Avatar
 
Join Date: Aug 2014
Location: welches, oregon
Posts: 3,148
Mentioned: 5 Post(s)
Garage
Send a message via Skype™ to silviefox
Quote:
Originally Posted by jaaklucas View Post
siviefox,I know were supposed to self-distance ourselves in this pandemic but I didnt know we were supposed to self-medicate!
always self medicating

yes im a guy.
Silvie=latin for. Of the forest /woods. Fox= Vulpine (also my middle name)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

"closed mindedness causes bliss in simple minded people"
silviefox is offline  
post #15 of 15 (permalink) Old 03-24-2020, 07:08 PM
Super Moderator
 
fasteddiecopeman's Avatar
 
Join Date: Jul 2008
Location: Kelowna, BC - summer; Florence, AZ - winter
Posts: 18,400
Mentioned: 34 Post(s)
Quote:
Originally Posted by jaaklucas View Post
siviefox,I know were supposed to self-distance ourselves in this pandemic but I didnt know we were supposed to self-medicate!
Quote:
Originally Posted by silviefox View Post
always self medicating
Let's here it for self-medicating!!!

(Sittin' here w/ a glass of Glenmorangie and water.......)
silviefox and jaaklucas like this.

Ed
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'08 V AZ, '15 V650LT BC
Ride to D2D 2013, June '13

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2015, June '15

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2016, June '16

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
fasteddiecopeman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome