Howdy from Charlotte, NC - Kawasaki Versys Forum
Member Introductions Just joined? Tell us about yourself and your ride.

 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 10-06-2018, 02:16 PM Thread Starter
Member
 
TimBo's Avatar
 
Join Date: Oct 2018
Posts: 4
Mentioned: 0 Post(s)
Howdy from Charlotte, NC

Having some stator issues on my 09 650, sounds like a relatively common problem. Looks like I need to make a few intro posts! Bought my kawi in 2015 with 400 miles on it, now up to 12k. Still runs solid except for this darn stator issue (two tows in one day = no fun at all).
TimBo is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 10-06-2018, 05:33 PM Thread Starter
Member
 
TimBo's Avatar
 
Join Date: Oct 2018
Posts: 4
Mentioned: 0 Post(s)
Seems like a good crew around here, looking forward to learning a thing or two!
TimBo is offline  
post #3 of 12 (permalink) Old 10-06-2018, 08:57 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 6,892
Mentioned: 28 Post(s)
Welcome from Canada

https://www.kawasakiversys.com/forum...ber-intro.html

Talk about odd, two members within days! You came to the right place. All technical info in How To Forum. Either under Stator or Polaris Regulator. Best to follow the advice I gave in this thread;
https://www.kawasakiversys.com/forum...-question.html

Last edited by onewizard; 10-06-2018 at 09:01 PM.
onewizard is offline  
 
post #4 of 12 (permalink) Old 10-06-2018, 10:28 PM
Super Moderator
 
Fastoman's Avatar
 
Join Date: Sep 2009
Location: Ipoh.Perak.Malaysia
Posts: 6,863
Mentioned: 6 Post(s)
My 09 is still running with the original stator with 60K km on the Odo. Maybe high time to get it replaced.
Fastoman is online now  
post #5 of 12 (permalink) Old 10-07-2018, 09:25 AM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 6,892
Mentioned: 28 Post(s)
Quote:
Originally Posted by Fastoman View Post
My 09 is still running with the original stator with 60K km on the Odo. Maybe high time to get it replaced.
I would upgrade to a Polaris Regulator.
onewizard is offline  
post #6 of 12 (permalink) Old 10-07-2018, 01:33 PM
Super Moderator
 
fasteddiecopeman's Avatar
 
Join Date: Jul 2008
Location: Kelowna, BC - summer; Florence, AZ - winter
Posts: 17,527
Mentioned: 25 Post(s)
aboard!

Ed
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'08 V AZ, '15 V650LT BC
Ride to D2D 2013, June '13

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2015, June '15

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2016, June '16

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
fasteddiecopeman is offline  
post #7 of 12 (permalink) Old 10-08-2018, 06:59 AM
Member
 
Join Date: Oct 2018
Location: Waxhaw (Weddington) NC
Posts: 6
Mentioned: 0 Post(s)
Another Greeting from Charlotte NC

Just joined Forum. Was searching for some answers regards my repeated stator failures on 2011 650, purchased in 2013, now with 22k miles. Failed last summer, so replaced stator and regulator. Just failed again last week. I found my answer here in multiple threads--I need to put in new stator and new Series Polaris regulator which I just ordered off Ebay. Makes sense--I commute in stop and go traffic in 90deg F weather--stator gets pretty hot.
I especially thank onewizard for all his expertise. I wonder why Kawi continue to install such poor OEM design (probably $$), but really bad business to keep installing bad OEM parts with such frequent failures. Thanks again
wamaynard is offline  
post #8 of 12 (permalink) Old 10-09-2018, 06:54 PM Thread Starter
Member
 
TimBo's Avatar
 
Join Date: Oct 2018
Posts: 4
Mentioned: 0 Post(s)
Wow, talk about a small world - wamaynard, I'm over in Indian Land, SC

Thanks for all the info, gents. Looks like I've got some homework to do!
TimBo is offline  
post #9 of 12 (permalink) Old 10-10-2018, 10:52 AM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 6,892
Mentioned: 28 Post(s)
Lucky I caught Your Post/ Not a Spammer

Quote:
Originally Posted by wamaynard View Post
Just joined Forum. Was searching for some answers regards my repeated stator failures on 2011 650, purchased in 2013, now with 22k miles. Failed last summer, so replaced stator and regulator. Just failed again last week. I found my answer here in multiple threads--I need to put in new stator and new Series Polaris regulator which I just ordered off Ebay. Makes sense--I commute in stop and go traffic in 90deg F weather--stator gets pretty hot.
I especially thank onewizard for all his expertise. I wonder why Kawi continue to install such poor OEM design (probably $$), but really bad business to keep installing bad OEM parts with such frequent failures. Thanks again
You just gained a post count, also I hope you purchased a verified by me 4012941 Polaris, as there are numerous fake ones out there.
onewizard is offline  
post #10 of 12 (permalink) Old 10-12-2018, 06:52 AM
Member
 
Join Date: Oct 2018
Location: Waxhaw (Weddington) NC
Posts: 6
Mentioned: 0 Post(s)
Onewizard I purchased Polaris Regulator-3Ph 50A Series 4016868 (was recommended by you on one of your earlier posts). I hope that works, plan to install it this weekend.
wamaynard is offline  
post #11 of 12 (permalink) Old 10-12-2018, 10:56 AM
Member
 
Join Date: Oct 2018
Location: Waxhaw (Weddington) NC
Posts: 6
Mentioned: 0 Post(s)
TimBo you are a short ride from me in Weddington. We'll have to get together as soon as I get the bike running again
wamaynard is offline  
post #12 of 12 (permalink) Old 10-12-2018, 12:58 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 6,892
Mentioned: 28 Post(s)
Quote:
Originally Posted by wamaynard View Post
Onewizard I purchased Polaris Regulator-3Ph 50A Series 4016868 (was recommended by you on one of your earlier posts). I hope that works, plan to install it this weekend.
Please post photos.If you need help, PM me.
onewizard is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome