New Versys Owner From Costa Rica - Kawasaki Versys Forum
Member Introductions Just joined? Tell us about yourself and your ride.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-03-2012, 09:28 PM Thread Starter
Member
 
Join Date: Sep 2012
Location: Costa Rica
Posts: 7
Mentioned: 0 Post(s)
New Versys Owner From Costa Rica

Hi everyone I've been riding a recently 2011 model for 2 weeks now that I purchased from a member of this forum!

Love this bike it has great design and lots of power. I'm getting use to its riding position and handling.

Jumped from a 2012 Yamaha FZ16... Love that bike but with only 160cc this new bike is a huge improvement for me!

Bike came with a lot of extras: carbon fiber hugger, crash bars, givi windshield, givi monokey rack system, continental tires, steel braided brake hoses, xenon headlights, led brake, turn signal and some other pluses.

I'm happy with the bike so far, just overwhelmed by an overheating problem I'm having right now, I think that cooling fan was damaged by a rock or something...!

I have a query, when I turn the key to on without turning the engine on I hear a sound coming from the tank, it last only a few seconds, is that normal? I guess is the fuel pump or something like that...
UpgradeCyrus is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-03-2012, 09:51 PM
MTS
Member
 
MTS's Avatar
 
Join Date: Mar 2011
Location: NW USA
Posts: 3,518
Mentioned: 0 Post(s)
The sound after turning your key on is normal. The heat problem isn't normal. Fan should come on and off. Some guys put thermobob.com on for better cooling and keeping motor warm in cold weather.





To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
( RIDE FREE BE SAFE )
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by MTS; 10-03-2012 at 09:54 PM.
MTS is offline  
post #3 of 4 (permalink) Old 10-04-2012, 01:48 AM
Member
 
AzItLies's Avatar
 
Join Date: Jan 2012
Posts: 622
Mentioned: 0 Post(s)
x

Last edited by AzItLies; 10-23-2012 at 12:54 PM.
AzItLies is offline  
 
post #4 of 4 (permalink) Old 10-04-2012, 07:20 PM Thread Starter
Member
 
Join Date: Sep 2012
Location: Costa Rica
Posts: 7
Mentioned: 0 Post(s)
Hi, thank you both!

Yeap it was a great deal, bike was running ok until I made a trip to the beach and hit some roads with gravel...

After that the issue began! I think is the fan that was jammed with a pebble or something and the motor failed to engage for cooling...

I plugged the fan directly to the battery and it didn't do anything so I think is toast!

I'm looking for a replacement...
UpgradeCyrus is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome