Versys indicator issues - Kawasaki Versys Forum
Member Introductions Just joined? Tell us about yourself and your ride.

 2Likes
  • 2 Post By Duffy
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-06-2018, 01:39 PM Thread Starter
Member
 
Hutchk's Avatar
 
Join Date: Mar 2018
Posts: 2
Mentioned: 0 Post(s)
Versys indicator issues

Hi all new member! Possibly could anyone help! Versys 650 2016. When I ride into work possible first 30 mins my hazard lights and indicators doesnít work! Then all of a sudden thy work. Same when I return from work and ride home! Just donít seem to work, but then all of a sudden I can indicate? Very strange
Hutchk is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-06-2018, 02:25 PM
Member
 
Join Date: Sep 2016
Location: Hot Springs, SD
Posts: 902
Mentioned: 2 Post(s)
I would start checking the grounds for that lighting system............bad grounds do weird things.
Duffy is offline  
post #3 of 6 (permalink) Old 03-06-2018, 07:08 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 6,920
Mentioned: 28 Post(s)
Welcome from Canada

]to the forum , please read;http://www.kawasakiversys.com/forums...ber-intro.html FYI that is what warranty is for
onewizard is offline  
 
post #4 of 6 (permalink) Old 03-07-2018, 07:41 AM
Member
 
andyversystheworld's Avatar
 
Join Date: Feb 2017
Location: Northern Illinois
Posts: 160
Mentioned: 0 Post(s)
Garage
What has already been said. Electrical problems are a pain, remember they are logical (thus my problem!). Begin checking from the source, so fuse connections, maybe replace the fuse (could be internement connection inside the fuse), ground connections, do a lot of wiggling, and take your time. Have fun!

BEST,
ANDY

"ALWAYS IN QUESTION, NEVER IN DOUBT".
Visit me at andyversystheworld on Facebook for Pictures and Updates.
andyversystheworld is offline  
post #5 of 6 (permalink) Old 03-07-2018, 12:24 PM
Super Moderator
 
fasteddiecopeman's Avatar
 
Join Date: Jul 2008
Location: Kelowna, BC - summer; Florence, AZ - winter
Posts: 17,554
Mentioned: 25 Post(s)
aboard!

As was already said - check/ clean your ground connections!

Ed
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


'08 V AZ, '15 V650LT BC
Ride to D2D 2013, June '13

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2015, June '15

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Ride to D2D 2016, June '16

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
fasteddiecopeman is offline  
post #6 of 6 (permalink) Old 03-07-2018, 01:20 PM Thread Starter
Member
 
Hutchk's Avatar
 
Join Date: Mar 2018
Posts: 2
Mentioned: 0 Post(s)
Thanks for information forgot I am in warranty so will just take it and get it looked at. However will check other comments made, such as grounding etc thank all
Hutchk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome