Hi there! - Kawasaki Versys Forum
Member Introductions Just joined? Tell us about yourself and your ride.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 07-26-2012, 10:42 AM Thread Starter
Member
 
hal9000's Avatar
 
Join Date: May 2012
Location: Valinhos, SP - Brazil
Posts: 7
Mentioned: 0 Post(s)
Hi there!

Hi!

Just bought (a month ago) a 2011/11 Versys 650 with 10K miles on it. Great bike, great and strong engine, good and reliable suspensions. Put some aftermarket parts (Puig windscreen, SW-Motech front sliders, GIVI hardbags and original handguards). Few days ago I've installed a pair of Michelin Pilot Road 3 and... wow! What a tyre! Having some issues with chain, three times in dealer to replace it, because o-rings tendo to tear and jump off. Anybody has had same problem?

Cheers!
hal9000 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-26-2012, 01:18 PM
Member
 
King.Versys's Avatar
 
Join Date: Apr 2012
Location: Austin, Texas
Posts: 692
Mentioned: 0 Post(s)
Welcome
King.Versys is offline  
post #3 of 9 (permalink) Old 07-26-2012, 02:05 PM
Member
 
AzItLies's Avatar
 
Join Date: Jan 2012
Posts: 622
Mentioned: 0 Post(s)
x

Last edited by AzItLies; 10-23-2012 at 01:49 PM.
AzItLies is offline  
 
post #4 of 9 (permalink) Old 07-26-2012, 02:06 PM
Member
 
s102000's Avatar
 
Join Date: Jun 2011
Location: Yorkville / Rockmart Ga
Posts: 222
Mentioned: 0 Post(s)
Quote:
Originally Posted by hal9000 View Post
Hi!

Just bought (a month ago) a 2011/11 Versys 650 with 10K miles on it. Great bike, great and strong engine, good and reliable suspensions. Put some aftermarket parts (Puig windscreen, SW-Motech front sliders, GIVI hardbags and original handguards). Few days ago I've installed a pair of Michelin Pilot Road 3 and... wow! What a tyre! Having some issues with chain, three times in dealer to replace it, because o-rings tendo to tear and jump off. Anybody has had same problem?

Cheers!
Welcome..

You've replaced the chain three times or had the o-rings replaced on the links three times?

Sold 2005 honda vtx 1300 bought an '09 versys
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
s102000 is offline  
post #5 of 9 (permalink) Old 07-26-2012, 03:12 PM
Member
 
Capn Kirk's Avatar
 
Join Date: Apr 2010
Location: Virginia USA
Posts: 4,740
Mentioned: 0 Post(s)
Capn Kirk is offline  
post #6 of 9 (permalink) Old 07-26-2012, 06:23 PM
Member
 
Baron650's Avatar
 
Join Date: May 2010
Location: Portland, OR
Posts: 943
Mentioned: 0 Post(s)
Welcome and glad you're enjoying the bike.
I've only lost an O-ring a couple times, and only on the rivet link after extended wear. Three chains in a month is really unusual. Is the chain tension put to spec every time? Maybe the sprockets are not aligned, like a spacer got put on the wrong side? Let us know what you find out.
Baron650 is offline  
post #7 of 9 (permalink) Old 07-26-2012, 06:50 PM
Super Moderator
 
kiwi 41's Avatar
 
Join Date: Mar 2010
Location: 44.24'S 171.15'E Timaru, NewZealand
Posts: 8,622
Mentioned: 2 Post(s)
Send a message via Skype™ to kiwi 41
Welcome, replaced my chain and sprockets at 28,000km, your chain issues sound very odd!

Last edited by kiwi 41; 07-26-2012 at 07:37 PM.
kiwi 41 is offline  
post #8 of 9 (permalink) Old 07-26-2012, 07:21 PM
Super Moderator
 
Fastoman's Avatar
 
Join Date: Sep 2009
Location: Ipoh.Perak.Malaysia
Posts: 6,889
Mentioned: 6 Post(s)


Chain issue is purely alignment . check sprockets & chain.

Fastoman is offline  
post #9 of 9 (permalink) Old 07-31-2012, 08:56 PM Thread Starter
Member
 
hal9000's Avatar
 
Join Date: May 2012
Location: Valinhos, SP - Brazil
Posts: 7
Mentioned: 0 Post(s)
Thanks!

sprocket alignment is also my main suspect. Because bike is still in its warranty, it was left at dealer this week. They'll do some measurements and check the alignment. Let's see what happens.
hal9000 is offline  
Sponsored Links
Advertisement
 
Reply

Tags
chain, o-ring, tyre

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome