Scorpion Taper Slip on Exhaust (issue) - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-07-2014, 10:17 PM Thread Starter
Member
 
BKKPhil's Avatar
 
Join Date: Sep 2013
Location: Thailand
Posts: 179
Mentioned: 0 Post(s)
Scorpion Taper Slip on Exhaust (issue)

Hi Folks,

Not an issue with the exhaust exactly

I have just installed a Scorpion exhaust which sounds great. However, a day after installation I had my bike serviced and the sound of the bike has changed.

The sound prior was clearly coming from the exhaust but during the ride home from service I can now hear a throaty sound from the front, radiator areas, more so than the exhaust with helmet on when riding. I have checked the downpipes and and tightened things up, but still the sound remains. There is no performance issues, just the addition of this sound.

I'm wondering if it is possibly from the air filter since it was cleaned during service. Induction noise possibly?

Any suggestions greatly appreciated.

Just to narrow things down, all joins from the down-pipe to muffler have been checked.

Thanks
BKKPhil is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-08-2014, 01:52 AM
Member
 
MaverickAus's Avatar
 
Join Date: Feb 2009
Location: Coffs Harbour, NSW, Australia
Posts: 2,039
Mentioned: 0 Post(s)
Garage
That would be my guess maybe they left it out?
MaverickAus is offline  
post #3 of 7 (permalink) Old 07-08-2014, 09:18 AM
Member
 
Join Date: May 2014
Location: St.Louis Mo
Posts: 41
Mentioned: 0 Post(s)
Would they have removed the "snorkel" for any reason?
I ran with mine removed for a short time. There was a noticeable increase in intake noise.
Pinchflat is offline  
 
post #4 of 7 (permalink) Old 07-08-2014, 11:14 AM
Member
 
IanThomas's Avatar
 
Join Date: Mar 2014
Location: New Hampshire USA
Posts: 805
Mentioned: 0 Post(s)
I was going to say make sure they put the filter back in.

- Ian Thomas
2013 Versys
IanThomas is offline  
post #5 of 7 (permalink) Old 07-19-2014, 01:50 PM Thread Starter
Member
 
BKKPhil's Avatar
 
Join Date: Sep 2013
Location: Thailand
Posts: 179
Mentioned: 0 Post(s)
Forgot to update. The little bleeders did indeed forget to put the filter back in!
BKKPhil is offline  
post #6 of 7 (permalink) Old 07-20-2014, 02:14 AM
Super Moderator
 
Join Date: Dec 2013
Location: Sydney Australia
Posts: 1,458
Mentioned: 4 Post(s)
Garage
LOL... nufties!
Gigitt is offline  
post #7 of 7 (permalink) Old 07-20-2014, 09:10 AM
Member
 
Apollo Bleed's Avatar
 
Join Date: May 2014
Location: The heart of Texas
Posts: 29
Mentioned: 0 Post(s)
Quote:
Originally Posted by BKKPhil View Post
Forgot to update. The little bleeders did indeed forget to put the filter back in!
I hope you asked for a free bike wash for the trouble. :-)
Apollo Bleed is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome