Oxford v0.8 Heated Grips install (VIDEO) - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 11-05-2013, 02:12 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Victoria BC
Posts: 21
Mentioned: 0 Post(s)
Oxford v0.8 Heated Grips install (VIDEO)

Hi All,

I'm sure there are plenty of these install videos floating around the internet, but I thought that since I was installing my new heated grips, I'd might as well make a video of it. These cost me CAD$150, tax included, from my local dealer.

VIDEO DISCLAIMER: I'm a noob.


POST INSTALL IMPRESSIONS: I love them! I love them! I love them!! Now that winter is on the way, these couldn't have been installed at a better time. Just yesterday I was riding to work in 2 degree (Celsius) weather. During my 15 minute commute, the grips get up to temperature in just a few minutes. I start out at 75% then switch to 50% once the gloves are to toasty warm. 100% is way too hot.
zordflea is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 11-05-2013, 03:36 PM
Member
 
Chicagobob's Avatar
 
Join Date: Jun 2011
Location: Chicago area
Posts: 9
Mentioned: 0 Post(s)
I like these also. I got a set for about $90 from Amazon.com, and installed them in about 15 minutes. They work well and really help. I've used them down to 25 degrees. At that temp, my hands feel cold (especially the thumbs), but are at least still mobile.
Chicagobob is offline  
post #3 of 18 (permalink) Old 11-05-2013, 06:53 PM
Member
 
Join Date: Jun 2011
Location: Waynesboro PA
Posts: 1,095
Mentioned: 0 Post(s)
I just installed a set of these last week. They are great.
Paid $49.95 from Twisted Throttle.
Install went easy. I mounted the controller on the bar using the supplied bracket and a bought clamp. Mounted the Heaterz brain box to the side of the battery box using the supplied double sided tape. The only issue during the install was I pinched the wire going to the grips in the steering stop as I was testing for full function of the steering and controls. The grips still work but I did a number on the wire.
I rode to work yesterday, it was 28F and I used 50%. 100% is just uncomfortable.
I was debating installing these through a relay to a switched circuit but I'm glad I didn't now, I'll go out to the garage and turn the Heaterz on (leaving the motorcycle off) a few minutes before I'm ready to leave so they're good and toasty when I hit the road. If they were on a switched circuit I would have to have the key and light on to do that.

Last edited by ray h; 11-05-2013 at 06:55 PM.
ray h is offline  
 
post #4 of 18 (permalink) Old 11-05-2013, 07:07 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Victoria BC
Posts: 21
Mentioned: 0 Post(s)
Quote:
Originally Posted by Chicagobob View Post
I like these also. I got a set for about $90 from Amazon.com, and installed them in about 15 minutes. They work well and really help. I've used them down to 25 degrees. At that temp, my hands feel cold (especially the thumbs), but are at least still mobile.
How on earth did you install in 15 minutes!?
But then again, I'm a noob at such things, and caution tends to slow me right down.
zordflea is offline  
post #5 of 18 (permalink) Old 11-05-2013, 07:26 PM
Member
 
Join Date: Jun 2011
Location: Waynesboro PA
Posts: 1,095
Mentioned: 0 Post(s)
Quote:
Originally Posted by zordflea View Post
How on earth did you install in 15 minutes!?
But then again, I'm a noob at such things, and caution tends to slow me right down.
I could see myself doing a 15 minute install if I had everything I needed sitting right infront of me and I had done it a couple times already.
My first time was last week and I had to make a Lowes run in the middle. Not including the Lowes trip, it probably took me about an hour and a half.
Removing the old grips took me longer than anything because I wanted them off intact, lots of wiggling, a screwdriver and air compressor and my grips came off without ruining them.
ray h is offline  
post #6 of 18 (permalink) Old 11-05-2013, 10:06 PM
Member
 
Join Date: Dec 2011
Location: California
Posts: 614
Mentioned: 0 Post(s)
Quote:
Originally Posted by ray h View Post
I just installed a set of these last week. They are great.
Paid $49.95 from Twisted Throttle.
Install went easy. I mounted the controller on the bar using the supplied bracket and a bought clamp. Mounted the Heaterz brain box to the side of the battery box using the supplied double sided tape.
If you have both of those, you didn't install the v8 controller that the OP mentioned--the version is probably marked on the front. The v8 is a simpler install, because there are fewer pieces to mount and less wire to route.
davidg is offline  
post #7 of 18 (permalink) Old 11-05-2013, 10:20 PM Thread Starter
Member
 
Join Date: Jun 2013
Location: Victoria BC
Posts: 21
Mentioned: 0 Post(s)
Quote:
Originally Posted by davidg View Post
If you have both of those, you didn't install the v8 controller that the OP mentioned--the version is probably marked on the front. The v8 is a simpler install, because there are fewer pieces to mount and less wire to route.
One of the reasons I made sure I could get the v0.8 was for the updated controller. I think of it as a major upgrade actually, with an easier installation and auto shutoff. I'm surprised that some people are having so much trouble finding the newest model.
zordflea is offline  
post #8 of 18 (permalink) Old 11-06-2013, 06:29 AM
Member
 
Join Date: Jun 2011
Location: Waynesboro PA
Posts: 1,095
Mentioned: 0 Post(s)
Quote:
Originally Posted by zordflea View Post
One of the reasons I made sure I could get the v0.8 was for the updated controller. I think of it as a major upgrade actually, with an easier installation and auto shutoff. I'm surprised that some people are having so much trouble finding the newest model.
You're right, I guess I do have a different controller. That explains the wild price differences.
Besides the installation of the other box, what is the upgrade? The one I have has the auto shutoff as well.

Last edited by ray h; 11-06-2013 at 06:44 AM.
ray h is offline  
post #9 of 18 (permalink) Old 11-06-2013, 08:11 AM
Member
 
Zatx's Avatar
 
Join Date: Jun 2012
Posts: 681
Mentioned: 0 Post(s)
Quote:
Originally Posted by ray h View Post
You're right, I guess I do have a different controller. That explains the wild price differences.
Besides the installation of the other box, what is the upgrade? The one I have has the auto shutoff as well.

The version 8 controller auto shut off actually works. Seriously don't trust the auto shut off on all previous versions of the controller. The other upgrade is all of the electronics are contained in that one small box, no need for two electronic boxes and the extra wiring.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


May the road always curve in front of you.
Zatx is offline  
post #10 of 18 (permalink) Old 11-22-2013, 10:33 AM
Member
 
Chicagobob's Avatar
 
Join Date: Jun 2011
Location: Chicago area
Posts: 9
Mentioned: 0 Post(s)
Quote:
Originally Posted by zordflea View Post
How on earth did you install in 15 minutes!?
But then again, I'm a noob at such things, and caution tends to slow me right down.
I have an ER6n, so all I had to do was remove the seat, the left tank cover, and headlight dash panel, remove the old grips, slip on the new, run the wires along the tank to the battery, replace the panels, and screw on the controller (to the dash panel). I stuffed the excess wires behind the headlight. It would have taken longer if I'd installed a relay, but Oxford has a battery saver function, and I've been safe so far.
Chicagobob is offline  
post #11 of 18 (permalink) Old 11-22-2013, 12:42 PM
Member
 
anders55's Avatar
 
Join Date: Oct 2011
Posts: 288
Mentioned: 0 Post(s)
Quote:
Originally Posted by Zatx View Post
The version 8 controller auto shut off actually works. Seriously don't trust the auto shut off on all previous versions of the controller. The other upgrade is all of the electronics are contained in that one small box, no need for two electronic boxes and the extra wiring.
I didn't trust the auto shut off. Connected my Oxfords to the headlight wire => motor running/headlight on => heat is on..

Anders B.
Sweden
anders55 is offline  
post #12 of 18 (permalink) Old 11-22-2013, 03:38 PM
Member
 
Zatx's Avatar
 
Join Date: Jun 2012
Posts: 681
Mentioned: 0 Post(s)
v.8's aut0-shut off works great. Have tested many times. Anything prior to v.8 I wouldn't trust at all.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


May the road always curve in front of you.
Zatx is offline  
post #13 of 18 (permalink) Old 11-22-2013, 10:06 PM
Member
 
Join Date: Dec 2011
Location: California
Posts: 614
Mentioned: 0 Post(s)
Quote:
Originally Posted by Zatx View Post
v.8's aut0-shut off works great. Have tested many times. Anything prior to v.8 I wouldn't trust at all.
The older ones were different.

My oldest one (don't know the version) shut off too easily. The bike it was on didn't charge at low RPMs and I think I had to get going sometimes to get the grips on.

The manual with my v.7a said it was supposed to shut off around 10.6-11V so as not to damage the battery. But that probably won't start your bike. Better than nothing but not ideal.

I came back to it once or twice when the bike wouldn't start, but the battery was fine. The grips were still on though, so I don't know if it would have worked. I only know I left them on for the work day a couple of times with no battery damage.

FWIW if I could see all the LEDs in daylight I might not have left them on. With the v.8 I can.

I agree the v.8 shut off does work as we would hope.
davidg is offline  
post #14 of 18 (permalink) Old 11-23-2013, 12:54 AM Thread Starter
Member
 
Join Date: Jun 2013
Location: Victoria BC
Posts: 21
Mentioned: 0 Post(s)
Quote:
Originally Posted by Zatx View Post
v.8's aut0-shut off works great. Have tested many times. Anything prior to v.8 I wouldn't trust at all.
I also can confirm that the auto shutoff on the v0.8 controller works as advertised. And this past week the temperature has dipped to below 0 degrees Celsius during my ride to work, so I really appreciate the heated grips. Still haven't used anything more than the 75% heat setting.
zordflea is offline  
post #15 of 18 (permalink) Old 11-23-2013, 07:26 AM
Member
 
Join Date: Sep 2012
Location: S. Connecticut
Posts: 23
Mentioned: 0 Post(s)
Lockitt.com Has them with free shipping. This is V.8

GPOX691 Oxford Premium Touring Heated Grips OF691Z 1 $74.95
andykisz is offline  
post #16 of 18 (permalink) Old 02-08-2014, 11:44 AM
Member
 
Join Date: Aug 2013
Location: Canada, eh.
Posts: 73
Mentioned: 0 Post(s)
Quote:
Originally Posted by zordflea View Post
Hi All,

I'm sure there are plenty of these install videos floating around the internet, but I thought that since I was installing my new heated grips, I'd might as well make a video of it. These cost me CAD$150, tax included, from my local dealer.

VIDEO DISCLAIMER: I'm a noob.

Kawasaki Versys 650 - Oxford Heated Grips Install

POST INSTALL IMPRESSIONS: I love them! I love them! I love them!! Now that winter is on the way, these couldn't have been installed at a better time. Just yesterday I was riding to work in 2 degree (Celsius) weather. During my 15 minute commute, the grips get up to temperature in just a few minutes. I start out at 75% then switch to 50% once the gloves are to toasty warm. 100% is way too hot.
Thanks for taking the time to film and post! I used your vid for my install the other night. It's been cold riding around here the last few days!

BTW, I think we have the exact same bike (year and colour) and both living in Victoria. Hope to see you around some time!
makinwaves is offline  
post #17 of 18 (permalink) Old 02-20-2014, 02:45 AM
Member
 
Join Date: Aug 2013
Location: Canada, eh.
Posts: 73
Mentioned: 0 Post(s)
Okay, so the double sided tape seems to only last for a few days. What have people done to keep their controller in place (who didn't mount it to the mirror)? Is there better tape out there?
makinwaves is offline  
post #18 of 18 (permalink) Old 01-10-2015, 05:19 PM
Member
 
mfd1719's Avatar
 
Join Date: May 2011
Location: Lexington Ohio
Posts: 43
Mentioned: 0 Post(s)
so which version of these grips are you guys installing. They measure differently in lengths. I believe I want the touring model as they measure the same as my grips now. I am running bark buster hand guards and think the adventure grips are to long. Great video on the install btw.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
mfd1719 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome