Hazard Lights Malfunction - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-01-2014, 10:11 AM Thread Starter
Member
 
kiko's Avatar
 
Join Date: Jun 2008
Location: Jalisco, MX
Posts: 242
Mentioned: 0 Post(s)
Hazard Lights Malfunction

Did not find anything with the search engine so here goes,

When I press the Hazard light button I get one flash of the lights and then nothing. The turn signals work fine. I checked for continuity at the switch and it is good. I assume the hazard and turn signals share the same fuse so that's not the problem. Any way the flasher itself could be bad for the hazard light but still work with the turn signals?? What else could the problem be?
kiko is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-01-2014, 11:54 AM
Member
 
BLACK DOG's Avatar
 
Join Date: Oct 2011
Location: frankfort, illinois
Posts: 1,456
Mentioned: 2 Post(s)
You may need to apply the wonder tool of the century...WD-40 & give it a couple extra pushes.
BLACK DOG is offline  
post #3 of 5 (permalink) Old 08-01-2014, 12:09 PM
Member
 
Join Date: Aug 2011
Location: Northern Italy
Posts: 130
Mentioned: 0 Post(s)
Do you have any extra turn signals added to your bike? I added a pair of turn signals to my saddle bags and the same thing happened to me. The funny thing though, when I remove my saddlebags and disconnect the wires, the hazard lights work fine. I assume it has something to do with resistance or load... I don't know. I figured having extra turn signals is more important than hazard lights.
Merlin3e9 is offline  
 
post #4 of 5 (permalink) Old 08-01-2014, 01:17 PM
Member
 
Join Date: Oct 2013
Posts: 1,607
Mentioned: 0 Post(s)
Silly me, I didn't know I had hazard lights. Anyway, if you swap the O.E.M. turn signal relay for a solid state aftermarket one they will work.
waltermitty is offline  
post #5 of 5 (permalink) Old 08-05-2014, 09:01 PM Thread Starter
Member
 
kiko's Avatar
 
Join Date: Jun 2008
Location: Jalisco, MX
Posts: 242
Mentioned: 0 Post(s)
Quote:
Originally Posted by waltermitty View Post
Silly me, I didn't know I had hazard lights. Anyway, if you swap the O.E.M. turn signal relay for a solid state aftermarket one they will work.
Finally found a solid state aftermarket relay and that did the trick. Thanks,
kiko is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome