Bad Brakes? - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-13-2009, 11:05 PM Thread Starter
Member
 
potus2012's Avatar
 
Join Date: Mar 2009
Location: NorthWest Arkansas
Posts: 543
Mentioned: 0 Post(s)
Bad Brakes?

The lever on the front brake is so soft it nearly hits the grip when fully squeezed. I have small hands so I have to adjust the knob to 4 to make it useful. Still it will pinch my last two fingers if I try a two finger stop. I also get a "grinding" feel when I get on the front brake moderately. I notice no pulsing at all, and the rotor looks clean with no grooves. I don't notice any brake dust accumulating anywhere either.
I bled the brakes today with little to no change in lever feel. The left caliper bled clean, but the first two squirts from the right caliper were black. Not amber or brown, but black. Didn't notice any air or separated water.
I've got less than 4000 miles on it.
Any ideas?

Back Off! I'm Already Riding Way Beyond My Abilities.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
potus2012 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-13-2009, 11:40 PM
Member
 
oxman's Avatar
 
Join Date: May 2008
Location: Innisfail, Alberta
Posts: 371
Mentioned: 0 Post(s)
sounds like your right side got a little hot and burnt your fluid in the caliper . Are you heavy on the front brakes and if so maybe upgrade to a race spec brake fluid . I use Ferodo fluid
http://www.ferodoracing.com/it/motor...fluid_pads.htm in all my bikes with good results.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by oxman; 07-13-2009 at 11:42 PM.
oxman is offline  
post #3 of 3 (permalink) Old 07-14-2009, 04:56 AM
Member
 
stlee29's Avatar
 
Join Date: Dec 2008
Location: Bukit Mertajam,Penang,Malaysia
Posts: 3,187
Mentioned: 0 Post(s)
Hi Potus2012,

3 thoughts:
1. The brake lever plunger seal damaged.
2. Very unlikely but check the brake pad lining thickness.
3. Dirty brake fluid


My V Blog:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ride safe,
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
stlee29 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome