Water pump leak - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-11-2009, 03:30 PM Thread Starter
Member
 
Join Date: May 2009
Posts: 207
Mentioned: 0 Post(s)
Water pump leak

I noticed a coolant smell and saw dried up white substance on the inside lower plastic cover. Bottom of water pump wet, took into dealer, new pump ordered. Not getting off to a very good start, only 2 weeks old.....better check yours.
mcrider is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-11-2009, 03:43 PM
Member
 
schleppy's Avatar
 
Join Date: Jul 2008
Location: Wenham, MA
Posts: 124
Mentioned: 0 Post(s)
Send a message via AIM to schleppy
Yay, another thing to worry about! I'll definitely check mine when I get home. The warranty is running out soon...
schleppy is offline  
post #3 of 5 (permalink) Old 06-11-2009, 07:25 PM
Member
 
Red Herring's Avatar
 
Join Date: Aug 2008
Location: Victoria BC
Posts: 779
Mentioned: 0 Post(s)
Been there, done that... well sort of. Mine just had to be retorqued. Been fine since.

2007 Versys Black, V35 Bags, H&B Bars, Skidmarx Hugger.Fender Ex., Avon Distanzia, Braided Lines, Hella 65W bulbs Arrow Can, DNA Air filter, GIVI tall screen (for winter), PCIII, Baldwin Saddle. **SOLD**

2011 KTM SM-T. Crash bars, E55 Top Box, Fender extender front and rear.
Red Herring is offline  
 
post #4 of 5 (permalink) Old 06-11-2009, 08:23 PM Thread Starter
Member
 
Join Date: May 2009
Posts: 207
Mentioned: 0 Post(s)
Quote:
Originally Posted by Red Herring View Post
Been there, done that... well sort of. Mine just had to be retorqued. Been fine since.
Wished mine was that simple.......mine leaks from the weep hole on the bottom. I'll just have to ride my trusty aircooled Nighthawk 750 in the meantime.

Last edited by mcrider; 06-11-2009 at 08:26 PM.
mcrider is offline  
post #5 of 5 (permalink) Old 06-11-2009, 11:00 PM
Member
 
Join Date: Mar 2008
Posts: 285
Mentioned: 0 Post(s)
Over 16,000 miles on my V and no problems yets. The valves are making some noise so I took it to the shop. They said the valves are within tolerance. I guess I'll take it back again when I hit 25,000 miles. I'm also on my 3rd set of tires.
jimstandinghorse is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome