ABS light - Kawasaki Versys Forum
Like Tree3Likes
  • 2 Post By Gigitt
  • 1 Post By Rider_Dave
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-05-2020, 07:46 PM Thread Starter
Member
 
Tracymulkey's Avatar
 
Join Date: Jan 2020
Posts: 10
Mentioned: 0 Post(s)
ABS light

Installed brake light modulator on my 2019 couple weeks passed abs light started coming on intermittently. Anyone know if there is a connection? (Pun intended)
Tracymulkey is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-09-2020, 01:07 AM
Super Moderator
 
Join Date: Dec 2013
Location: Sydney Australia
Posts: 1,463
Mentioned: 6 Post(s)
Garage
Should not be related.
BLM only taps into the rear light harness. (unless it was universal and wire spliced and you did something wrong)

as a start... check ABS sensors at wheels and cables have not been hit by something and damaged.
Gigitt is offline  
post #3 of 6 (permalink) Old 03-17-2020, 08:07 PM
Member
 
Rider_Dave's Avatar
 
Join Date: Mar 2020
Posts: 12
Mentioned: 0 Post(s)
Try cleaning the ABS sensor mate.
dadsafrantic likes this.

Adventure before dementia.
Rider_Dave is offline  
 
post #4 of 6 (permalink) Old 03-20-2020, 07:25 PM Thread Starter
Member
 
Tracymulkey's Avatar
 
Join Date: Jan 2020
Posts: 10
Mentioned: 0 Post(s)
No damage to components sensors are clean. Disconnected brake light modulator. All good till a couple of days ago. Light came back on, stopped and re started. Light went out as normal upon pulling out. Looks like a warranty deal to me. Oh crap!
Tracymulkey is offline  
post #5 of 6 (permalink) Old 03-20-2020, 08:53 PM
Member
 
jaaklucas's Avatar
 
Join Date: Feb 2016
Location: Vancouver B.C.
Posts: 469
Mentioned: 3 Post(s)
Quote:
Originally Posted by Tracymulkey View Post
No damage to components sensors are clean. Disconnected brake light modulator. All good till a couple of days ago. Light came back on, stopped and re started. Light went out as normal upon pulling out. Looks like a warranty deal to me. Oh crap!
Never seen this on my 2015, ABS never acted up....
jaaklucas is offline  
post #6 of 6 (permalink) Old 03-23-2020, 05:00 PM Thread Starter
Member
 
Tracymulkey's Avatar
 
Join Date: Jan 2020
Posts: 10
Mentioned: 0 Post(s)
Wonder if the computer on a 2019 might be different than previous years
Tracymulkey is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome