Gauge Cluster Failure - Assistance Needed - Kawasaki Versys Forum
 2Likes
  • 2 Post By invader
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-06-2018, 01:48 PM Thread Starter
Member
 
Join Date: May 2018
Location: Calgary AB
Posts: 6
Gauge Cluster Failure - Assistance Needed

So my gauge cluster piled up on me (It's an 07 650). Only lights up. Signals work, low and high beam, but no tach, speedo or fuel. Lights up as a blank screen. So I did some trouble shooting in the harness. No obvious issues. So I go to ebay and order me used unit off an 11 with similar km on it. Thought I was off to the races.

But then I go and flip them around and realized the 07 has a hard wired pigtail, while the 11 has the connector on it.

See pic below

https://photos.app.goo.gl/X9FsgPk9FLTWAOJ92

So my question to the esteemed members is does anyone know where I can get the connector (with some wires on it) for the 11 gauge cluster so I can do some slicing and splicing to get it to work? The microfiche doesn't show a connector, just a complete harness, and I've found nothing on the web via all the searching I've done. But I'd bet someone in the community had come across this.

Thanks for the help!!

Kawibunga
Kawibunga is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-07-2018, 12:44 AM
Member
 
invader's Avatar
 
Join Date: Mar 2008
Location: Kapuskasing Ontario Canada
Posts: 7,815
You can get it from the main harness of a 2009+ Versys 650.

https://www.ebay.com/itm/12-Kawasaki...JZXojp&vxp=mtr

https://www.ebay.com/itm/09-Kawasaki...1Z210h&vxp=mtr

https://www.ebay.com/itm/09-Kawasaki...ZYQNmJ&vxp=mtr
onewizard and unstable_rider like this.

Last edited by invader; 06-07-2018 at 01:07 AM.
invader is offline  
post #3 of 5 (permalink) Old 06-07-2018, 09:22 AM Thread Starter
Member
 
Join Date: May 2018
Location: Calgary AB
Posts: 6
Thanks for the info Invader. I wasn't sure if it came on the main harness or was a separate cable. I'll get a used harness coming. Probably not a bad idea anyways for spares.

PS: The invader handle makes me wonder if you have an early 80s Invader kicking around, nice old sleds.

Thx

Kawibunga
Kawibunga is offline  
 
post #4 of 5 (permalink) Old 07-16-2018, 02:11 PM Thread Starter
Member
 
Join Date: May 2018
Location: Calgary AB
Posts: 6
Thought I'd post an update.

Wiring up a pigtail off the newer gauge worked like a hot damn. The colours of the wire are pretty much identical, but there was one wire which did not match. So via the process of elimination I spliced those two together last. But everything worked great.

Soldering well underway
https://photos.app.goo.gl/biEyJiTdifHyNWaj9

Last set or wires that did not match (Dark Green w/ White Strip - Light Green with Black Stripe)
https://photos.app.goo.gl/PKoGoAzHM89JZtPZ7

Finished product before tape and install
https://photos.app.goo.gl/ZxuoFNyDymHVfP2X9

Working like a hot damn
https://photos.app.goo.gl/xfrmS3EmHVqG3X1RA

Cheers,
Kawibunga is offline  
post #5 of 5 (permalink) Old 07-16-2018, 02:42 PM
Member
 
Arion's Avatar
 
Join Date: Oct 2010
Location: San Antonio, TX & Moosehead Lake, ME
Posts: 3,264
It's good to hear that SOMETHING goes right now and then. Seems nothing is easy any longer and nothing works as advertised. It also seems too commonplace that when the long-awaited gadget finally arrives the instruction photos don't look much like what you're holding in your hand. So, well done with your gauge cluster effort. Oh yeah, and hot damn!

Arion

"Plan? Plan! There ain't no plan."
Pig Killer, Mad Max Beyond Thunderdome
Arion is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome