LED Light Hyperflash - Kawasaki Versys Forum
 2Likes
  • 1 Post By onewizard
  • 1 Post By 1largebarge
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-27-2018, 11:06 AM Thread Starter
Member
 
1largebarge's Avatar
 
Join Date: Apr 2016
Location: Kenosha, Wi
Posts: 52
Garage
LED Light Hyperflash

Hey Guys,

Hoping you can help me understand what’s going on with my V. I installed aftermarket mirrors with built in LED turn signals so I could delete the stock ones as they stick out very far and are fairing destroyers. Just the cheap eBay ones were purchased.

http://r.ebay.com/6vxeEP

I was expecting hyperflash when installed due to the LEDs, but what I got is a INTERMITENT hyperflash. The turn signals start off normal speed and then speed up after being left on for a few seconds.

Is this normal? Will a new blinker modular fix this issue or cause the blinkers to start of very slowly then jump to normal speed?

Anybody seen this before?

Ring Rippers Founding Father
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
[/FONT]
1largebarge is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-27-2018, 11:53 AM
Member
 
Indelibility's Avatar
 
Join Date: May 2017
Location: Cornelius, NC
Posts: 228
Garage
You'll just need to install a flasher relay
Indelibility is offline  
post #3 of 4 (permalink) Old 05-27-2018, 08:07 PM
Super Moderator
 
Join Date: Nov 2008
Location: Kitchener Ontario
Posts: 6,469
3 wire electronic adjustable flasher

Quote:
Originally Posted by 1largebarge View Post
Hey Guys,

Hoping you can help me understand what’s going on with my V. I installed aftermarket mirrors with built in LED turn signals so I could delete the stock ones as they stick out very far and are fairing destroyers. Just the cheap eBay ones were purchased.

http://r.ebay.com/6vxeEP

I was expecting hyperflash when installed due to the LEDs, but what I got is a INTERMITENT hyperflash. The turn signals start off normal speed and then speed up after being left on for a few seconds.

Is this normal? Will a new blinker modular fix this issue or cause the blinkers to start of very slowly then jump to normal speed?

Anybody seen this before?
I bought my flasher for $3 from China, adjustable and 3 wire. This is a timed relay that you adjust the flash rate, independent of load. The reason yours does what it does is due to the rear signal bulbs. Most flashers use the current through them to produce a flash rate dependent on current, actually there is a voltage drop across the device which produces a charge and holds the relay open, since there is a current reduction with the led mirrors the on cycle is reduced, once the filament of the rear signal lights heat up, the current drops, adding to the shortened on time. I picked this one due to a better photo https://www.ebay.com/itm/Turn-Signal...UAAOSwMmBVxqeS
unstable_rider likes this.

Last edited by onewizard; 06-13-2018 at 04:07 PM.
onewizard is offline  
 
post #4 of 4 (permalink) Old 06-05-2018, 11:34 AM Thread Starter
Member
 
1largebarge's Avatar
 
Join Date: Apr 2016
Location: Kenosha, Wi
Posts: 52
Garage
Flasher relay resolved the problem, thanks for the help!
aboyandhisversys likes this.

Ring Rippers Founding Father
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
[/FONT]
1largebarge is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome