Cannot get clutch cable to connect - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-26-2017, 08:22 AM Thread Starter
Member
 
Join Date: May 2017
Location: Adelaide, South Australia
Posts: 42
Mentioned: 0 Post(s)
Cannot get clutch cable to connect

Having a strange issue. Had to replace my frayed clutch cable on my 07 Versys. I've routed it through the bike but the little metal spigot that clips through the clutch loop, I cannot for the life of me get it through the little link. I spent a hour fiddling with it, then my mate who has a far better mechanical knowledge that me so had a go, ..with no luck. It just won't fit through the link properly.

Anyone have any tips for getting it on? It's the correct cable. The old one popped off quite easily.
Coopz is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-26-2017, 01:52 PM
Member
 
silviefox's Avatar
 
Join Date: Aug 2014
Location: welches, oregon
Posts: 3,139
Mentioned: 5 Post(s)
Garage
Send a message via Skype™ to silviefox
are you trying to hook the clutch end first or have the handle end first? and also did you take all the slack out of the middle adjuster?

yes im a guy.
Silvie=latin for. Of the forest /woods. Fox= Vulpine (also my middle name)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

"closed mindedness causes bliss in simple minded people"
silviefox is offline  
post #3 of 5 (permalink) Old 10-26-2017, 04:32 PM Thread Starter
Member
 
Join Date: May 2017
Location: Adelaide, South Australia
Posts: 42
Mentioned: 0 Post(s)
Clutch end first, the cable has been threaded through to the handle but not connected.
Coopz is offline  
 
post #4 of 5 (permalink) Old 10-26-2017, 05:57 PM
Member
 
silviefox's Avatar
 
Join Date: Aug 2014
Location: welches, oregon
Posts: 3,139
Mentioned: 5 Post(s)
Garage
Send a message via Skype™ to silviefox
Quote:
Originally Posted by Coopz View Post
Clutch end first, the cable has been threaded through to the handle but not connected.
is the middle adjuster fully tightened in? after doing that ive always found getting the end into the clutch arm first (rest of the cable free) then pull the sheath part up into its holder, then get the barrel part in to the lever and start removing slack by adjusting the middle adjuster first to take out 3/4 of the slack then use the one at the handle for the rest

yes im a guy.
Silvie=latin for. Of the forest /woods. Fox= Vulpine (also my middle name)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

"closed mindedness causes bliss in simple minded people"
silviefox is offline  
post #5 of 5 (permalink) Old 10-26-2017, 08:12 PM Thread Starter
Member
 
Join Date: May 2017
Location: Adelaide, South Australia
Posts: 42
Mentioned: 0 Post(s)
Thanks mate, was able to get it in, it was just extremely fiddly, done a few cables in the past, first time I really struggled with a simple job=p
Coopz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome