Coolant Temp Indicator - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-29-2008, 05:41 AM Thread Starter
THR
Member
 
Join Date: Sep 2008
Location: Lunas, Malaysia
Posts: 14
Mentioned: 0 Post(s)
Coolant Temp Indicator

Hi there... I just bought my new V 22 days ago! I'm from Malaysia n' the bike is similar to our friend in Canada (read: Canadian's spec). Just wondering is it normal for the coolant indicator at meter cluster/guage for not lit up when we put the ignition switch at 'on' position, before we crank the motor? So far i only saw oil pressure n' FI indicators being lit up for system self diagnosed n' not the coolant temp indicator. Shouldn't the coolant temp indicator lit up too for the same reason? Thank you...
THR is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-29-2008, 01:43 PM
Member
 
amir_zwara's Avatar
 
Join Date: Jun 2008
Location: Tempe, AZ
Posts: 813
Mentioned: 0 Post(s)
I'm not sure, I will check in a few minutes and post back to ya when I get to work.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
amir_zwara is offline  
post #3 of 4 (permalink) Old 10-29-2008, 02:27 PM
Member
 
amir_zwara's Avatar
 
Join Date: Jun 2008
Location: Tempe, AZ
Posts: 813
Mentioned: 0 Post(s)
So over here in the US, the rad. collant light does NOT turn on when the rest of those dashboard lights do.
I guess it only turns on when you need it to... but how do you know if the bulb is still any good or not if you can't check it on a normal basis?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
amir_zwara is offline  
 
post #4 of 4 (permalink) Old 10-29-2008, 10:49 PM Thread Starter
THR
Member
 
Join Date: Sep 2008
Location: Lunas, Malaysia
Posts: 14
Mentioned: 0 Post(s)
Quote:
Originally Posted by amir_zwara View Post
... but how do you know if the bulb is still any good or not if you can't check it on a normal basis?

Yes... that is my main concern. how do we know if the bulb is working...

So the summary is, the coolant/radiator indicator does not lit up to tell ya whether they working or not. Thanks amir.

Last edited by THR; 10-30-2008 at 02:49 AM.
THR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome