Dash problem - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-26-2011, 06:47 PM Thread Starter
Member
 
Join Date: May 2010
Posts: 33
Mentioned: 0 Post(s)
Dash problem

Alright, for some time now I've had a problem with the Mode & Reset buttons on my dash. At first they would only work from time to time, if I pushed it just right, hopped on one foot and whistled dixie all at the same time! But now they're simply not working at all. I've taken the dash apart but can't seem to find what the problem is; the buttons feel good and seem to work fine when I push on them. Any help would be appreciated. Here are some pictures.

The dash (with the front cover plate off) showing the two guilty buttons on the left. When I push down on the white pieces inside the holes, I can feel the button clicking down and then pushing back up.



The back of the electronics boards, with circled in red, the back side of those two buttons.



Is the electronics board removable???

I was able to remove these two screws...



Un-snapped the white plastic tab in the top/center of the above picture, but the electronics board still wouldn't come off.

Do I have to un-bend these tabs??? (center of picture)



I didn't touch these as I was afraid of breaking something.


Please help; I'd really love to be able to see what my total mileage is and use the trip meter!
xc rider is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-26-2011, 06:54 PM
Member
 
Join Date: Nov 2010
Location: western NC
Posts: 78
Mentioned: 0 Post(s)
....several posters have sprayed CRC contact cleaner onto the contact point of the switches and have had a long lasting cure

...you are already there
rcfield is offline  
post #3 of 5 (permalink) Old 10-26-2011, 08:12 PM
Member
 
stlee29's Avatar
 
Join Date: Dec 2008
Location: Bukit Mertajam,Penang,Malaysia
Posts: 3,187
Mentioned: 0 Post(s)
Yup, CRC contact cleaner worked for me.

My V Blog:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ride safe,
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
stlee29 is offline  
 
post #4 of 5 (permalink) Old 10-29-2011, 09:54 AM
Member
 
Baron650's Avatar
 
Join Date: May 2010
Location: Portland, OR
Posts: 943
Mentioned: 0 Post(s)
For me it was the Reset only and the CRC didn't solve it. The Mode button still works and I reset the clock with a noon battery disconnect/re-connect. So, no trip meters but ODO & Clock. Fuel gauge and GPS take care of the rest.
Baron650 is offline  
post #5 of 5 (permalink) Old 10-29-2011, 10:32 AM
Member
 
if6was9's Avatar
 
Join Date: Sep 2009
Location: Columbus, Ohio
Posts: 111
Mentioned: 0 Post(s)
Take a (very) close look at the circuit board for hair line cracks in the solder or board. best done with a powerful magnifying glass. Sometime you can't even see them, so a circuit tester is needed. Cleaning the switch should have done the trick. I'd say the problem is the switch, or a problem with the board.
Say, what type of lamp illuminates the tach?

"I read somewhere that 77 per cent of all the mentally ill live in poverty. Actually, I'm more intrigued by the 23 per cent who are apparently doing quite well for themselves." -- Jerry Garcia

Last edited by if6was9; 10-29-2011 at 10:52 AM.
if6was9 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome