Charging system problem - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 09-24-2011, 06:49 PM Thread Starter
Member
 
sharrison56's Avatar
 
Join Date: Jun 2008
Location: Roswell, GA
Posts: 1,838
Mentioned: 0 Post(s)
Charging system problem

I am having a problem with the charging system. It is providing enough power for it to run, but not to charge the battery. I have replaced the stator and voltage reglator. It appears that I am getting plenty of power from the alternator, but I get less than 1/2 volt increase at 4,000 rpm at the battery so the battery won't charge. I unnderstand that I should be getting around 14v at 4K, but I only get 12v. Oh, I also replaced the battery.

Steve

I bought a motorcycle because my wife said that I couldn't! Now I have two and she still says I can't have another one!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Sounds like a challenge to me!

Now I have four!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sharrison56 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-25-2011, 02:38 PM Thread Starter
Member
 
sharrison56's Avatar
 
Join Date: Jun 2008
Location: Roswell, GA
Posts: 1,838
Mentioned: 0 Post(s)
It looks like te problem was bad connections at the main relay. I put electrical grease on all of them and it appears to be working now.

Steve

I bought a motorcycle because my wife said that I couldn't! Now I have two and she still says I can't have another one!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Sounds like a challenge to me!

Now I have four!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sharrison56 is offline  
post #3 of 5 (permalink) Old 09-25-2011, 02:45 PM
Member
 
gti20vturbo's Avatar
 
Join Date: Nov 2008
Posts: 926
Mentioned: 0 Post(s)
Thats good news. How much was the stator and rectifier? I curious in case I have a stator issue later.

ST1300, Versys, SV650S

Last edited by gti20vturbo; 09-25-2011 at 02:47 PM.
gti20vturbo is offline  
 
post #4 of 5 (permalink) Old 09-25-2011, 03:00 PM Thread Starter
Member
 
sharrison56's Avatar
 
Join Date: Jun 2008
Location: Roswell, GA
Posts: 1,838
Mentioned: 0 Post(s)
I will have to look, but I found the best price at Ronayers.com. It takes them a while to ship, but they have good prices and don't screw you on shipping.

Steve

I bought a motorcycle because my wife said that I couldn't! Now I have two and she still says I can't have another one!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Sounds like a challenge to me!

Now I have four!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
sharrison56 is offline  
post #5 of 5 (permalink) Old 09-26-2011, 02:21 AM
Super Moderator
 
Fastoman's Avatar
 
Join Date: Sep 2009
Location: Ipoh.Perak.Malaysia
Posts: 6,770
Mentioned: 6 Post(s)
Glad you got it solved..

Fastoman is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome