Fan Relay Location? - Kawasaki Versys Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 06-26-2011, 10:33 PM Thread Starter
Member
 
mminob's Avatar
 
Join Date: Nov 2008
Location: San Diego,California
Posts: 176
Mentioned: 0 Post(s)
Fan Relay Location?

My Radiator Fan was stuck, so I worked it back and forth, and it spins freely,and I put 12 volts to the fan motor, and the fan runs fine ,but on the dash,the warning light does not light up with the key on...should it? I was riding in stop and go traffic on a hot day the other day and I think the fan should have come on...it did not So could someone tell me where the Fan Relay is located on my 09... I checked the Fan Fuse and it's ok...Thanks...Suggestions?

2013 White 650 Versys...Purrs like a kitty cat...
2007 Yamaha WR250F...Dirt Ripper...
mminob is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 06-26-2011, 10:58 PM
Member
 
stlee29's Avatar
 
Join Date: Dec 2008
Location: Bukit Mertajam,Penang,Malaysia
Posts: 3,187
Mentioned: 0 Post(s)
Hope this help from the service manual:

Page 89


Page 146

page 552


Page 572


Also service code table on page 115. Cheers!

My V Blog:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ride safe,
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
stlee29 is offline  
post #3 of 7 (permalink) Old 06-27-2011, 12:25 AM Thread Starter
Member
 
mminob's Avatar
 
Join Date: Nov 2008
Location: San Diego,California
Posts: 176
Mentioned: 0 Post(s)
Thank you...

Your posting of pages has been very helpful stlee29 . I will investigate and let you know what I find...I'm having trouble getting the codes to display on the dash...I touch the diagnostic wire to ground quickly 5 times in 2 seconds but don't see anything happening on the dash...?

2013 White 650 Versys...Purrs like a kitty cat...
2007 Yamaha WR250F...Dirt Ripper...
mminob is offline  
 
post #4 of 7 (permalink) Old 06-27-2011, 06:50 AM
Member
 
invader's Avatar
 
Join Date: Mar 2008
Location: Kapuskasing Ontario Canada
Posts: 7,844
Mentioned: 4 Post(s)
It won't display codes if none are memorized. Current codes are displayed by grounding it once (and keeping it grounded with ignition on). Code 14 would indicate a problem with the water temperature sensor circuit... Are you sure it got hot enough to activate the fan?
Water temperature sensor removal/installation, output voltage inspection and resistance inspection procedures are on pages 129 and 130.
invader is offline  
post #5 of 7 (permalink) Old 06-27-2011, 07:16 AM
Member
 
stlee29's Avatar
 
Join Date: Dec 2008
Location: Bukit Mertajam,Penang,Malaysia
Posts: 3,187
Mentioned: 0 Post(s)
Glad Invader also came in to help out your problem.
Hope you get the fan back up and running soon when the engine gets hot.

My V Blog:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Ride safe,
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
stlee29 is offline  
post #6 of 7 (permalink) Old 07-06-2011, 10:22 PM
Member
 
Join Date: Sep 2008
Location: Quebec
Posts: 173
Mentioned: 0 Post(s)
Any progress on this?

Tomorrow I am digging in too, my fan stopped working yesterday- it spins by hand, but it doesn't kick in- discovered this when the fluid started to boil, without the warning light coming on...
allriding is offline  
post #7 of 7 (permalink) Old 07-22-2011, 01:09 PM Thread Starter
Member
 
mminob's Avatar
 
Join Date: Nov 2008
Location: San Diego,California
Posts: 176
Mentioned: 0 Post(s)
Fan is Working Again...

Quote:
Originally Posted by allriding View Post
Any progress on this?

Tomorrow I am digging in too, my fan stopped working yesterday- it spins by hand, but it doesn't kick in- discovered this when the fluid started to boil, without the warning light coming on...
I took a chance and ordered a Coolant Temp Switch for $50 and installed it...and bingo...the fan works and cycles on and off perfectly now...also changed the fluid while I was in there...The sensor is really easy to change...Thanks guys for all your help...

2013 White 650 Versys...Purrs like a kitty cat...
2007 Yamaha WR250F...Dirt Ripper...
mminob is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Versys Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome